Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 86043

Summary: Cannot download or view attachments
Product: [Retired] Red Hat Linux Reporter: Robert G. 'Doc' Savage <dsavage>
Component: squirrelmailAssignee: Gary Benson <gbenson>
Status: CLOSED DUPLICATE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-21 01:53:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Robert G. 'Doc' Savage 2003-03-12 23:31:47 UTC
Description of problem:
All attempts to "download" or "view" attachments produce an error message.


Version-Release number of selected component (if applicable): 1.2.10-1 and 1.2.11


How reproducible: 100%


Steps to Reproduce:
1.Open up Squirrelmail e-mail message
2.Click on _Download this as a file_, or
3.Click on _view_, or
4.Click on _download_, or
5.Click on URL such as _untitled-[2]_
    
Actual results:
Error message:
Parse error: parse error, unexpected ')' in
/usr/share/squirrelmail/src/download.php on line 337


Expected results: The attachment should either be displayed or begin downloading.


Additional info:
Line 337 in /usr/share/squirrelmail/src/download.php reads:
   $filename = 'untitled' . strip_tags($passed_ent_id) .$suffix);
                                                               ^error?

Comment 1 Gary Benson 2003-03-13 09:37:03 UTC

*** This bug has been marked as a duplicate of 85860 ***