Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 85998

Summary: REMOTEHOST not always set during rsh or rlogin
Product: [Retired] Red Hat Linux Reporter: Bill Heiden <bill.heiden>
Component: rshAssignee: Radek Vokal <rvokal>
Status: CLOSED CURRENTRELEASE QA Contact: Ben Levenson <benl>
Severity: high Docs Contact:
Priority: medium    
Version: 7.2CC: jimriggs
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-11-01 21:33:12 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bill Heiden 2003-03-11 23:29:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
 The environment variable REMOTEHOST is not always getting set when using 
rsh/rlogin to remotely log into a RH v7.2 machine.  This is a strange one, 
since there is no discernable pattern of why this is failing. I can rsh/rlogin 
into a RH v7.2 machine and sometimes REMOTEHOST does not get set. If I reboot 
the machine that is the destination, then it appears to work for a bit of 
time.  

Version-Release number of selected component (if applicable):
rsh-0.17-5

How reproducible:
Sometimes

Steps to Reproduce:
1.rsh/rlogin into v7.2 machine
2. env|grep REMOTE
If the remote login has successfully set $REMOTEHOST, then step 2 should 
produce something along the lines of:

 REMOTEHOST=machinename@domainName
    

Additional info:

 Within our current production environment, we commonly log into remote 
machines.  During any type of login, we test to see if REMOTEHOST is defined.  
If REMOTEHOST is not defined, we launch an application that changes the color 
profile of the machine's graphics card.  During a remote login the application 
that changes the color profile gets launched and core dumps if REMOTEHOST is 
not defined.  This extremely annoying and is preventing us from putting in any 
other logic that would allow us to tailor our logins.

Comment 1 Bill Heiden 2003-03-25 03:32:47 UTC
 This only appears to be a problem on the first windowed-shell opened on the 
machine, or at least that's how it's behaving today.  I'm a little confused 
though, is the first windowed shell pts/0 or pts/1?  The odd thing is the 
problem seems to come and go and we haven't been able to specifically put a 
finger on what exactly is causing the problem. 

Comment 2 Phil Knirsch 2003-06-25 15:01:13 UTC
Have you been able to reproduce it consistently in the meantime? A bug that not
really reproducible is very difficult to fix.

Read ya, Phil

Comment 3 Radek Vokal 2004-11-01 21:33:12 UTC
I wasn't able to reproduce this bug recently. It seems to be fixed in current
realease.