Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 85905

Summary: problem with keyboard and shortcuts
Product: [Retired] Red Hat Linux Reporter: Pavel Lisy <pali>
Component: sawfishAssignee: Havoc Pennington <hp>
Status: CLOSED WONTFIX QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-10-04 06:26:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Pavel Lisy 2003-03-10 17:25:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
In beta phoebe (tested in .93, .94) I have strange problems with shortcuts.
Normaly I use shortcut for starting gnome-terminal Ctrl-Meta-x or Ctrl-Shift-x
(for root term). Both have the same problem.
Terminal is started after several shortcut pressing and sometimes is started
more than one times. It seems to be nondeterminable how many terminals are started.

I try it on two computers on two beta variants.

In metacity is this OK. So it seems to be problem of sawfish.

I use cs_CZ or cs_CZ.UTF-8 locale.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. define shortcut Ctrl-Meta-x to run command gnome-terminal
2. press Ctrl-Meta-x
3. often nothing apears
4. press Ctrl-Meta-x
5. one or two gnome-terminal's are started
    

Additional info:

I use it very often and it is very annoying, it is not ready for production use.

Comment 1 Pavel Lisy 2003-03-12 07:43:57 UTC
It seems that problems are with chars in shortcuts. Many times when I press x or
c (which are in shortcuts) nothink hapens, I must press it second times. Often I
must rewrite words with x or c because they missing. 

The same behaviour I saw in both beta Phoebe versions (.93, .94)


Comment 2 Pavel Lisy 2003-03-16 09:56:52 UTC
I tested it again and found: 
than I set in Keyboard preferences 
longest delay and medium speed it works right or disabled keyboard repeating. 
So it seems to be problem in sawfish interpretation of concurrent keyboard pressing.

Is any capable debug it? 

Comment 3 Havoc Pennington 2003-10-04 06:26:19 UTC
This bug should be reported to http://bugzilla.gnome.org vs. the sawfish product
there, if still present in the latest release. Sawfish is provided on an
"as-shipped-by-upstream" basis (though please report any packaging issues
introduced by us).

Comment 4 Pavel Lisy 2003-10-09 08:30:43 UTC
I found for Redhat 9 solution in sawfish list, after I have used patch for
XFree86 4.3 and recompile it, sawfish work right. 

It seems that this problem is no more in new Fedora Core 0.94. I have installed
Fedora on two machines (one upgrade with up2date, second new install from CD)
and I don't remember similar problem.