Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 85877

Summary: r-c-samba won't start in French
Product: [Retired] Red Hat Linux Reporter: Yu Shao <yshao>
Component: redhat-config-sambaAssignee: Brent Fox <bfox>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: dr.linux, eng-i18n-bugs, stephane.jourdan
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-05-09 03:49:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Yu Shao 2003-03-10 05:32:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
r-c-samba won't start in French locale, but it works ok in en_US and zh_CN

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.set language as fr-FR and run redhat-config-samba or just simply run it this
way "LANG=fr_FR.UTF-8 redhat-config-samba"
2.
3.
    

Actual Results:  

[root@fnord root]# redhat-config-samba
Traceback (most recent call last):
  File "/usr/share/redhat-config-samba/redhat-config-samba.py", line 20, in ?
    mainWindow.MainWindow(debug_flag)
  File "/usr/share/redhat-config-samba/mainWindow.py", line 114, in __init__
    self.propertiesMenu = self.actionMenu.get_children()[1]
IndexError: list index out of range

Expected Results:  

redhat-config-samba starts normally

Additional info:

Comment 1 Brent Fox 2003-03-18 19:47:44 UTC
Should be fixed in Rawhide.  The French translations in the "File" menu were
only partially translated and that was causing GTK to create two "File" menus. 
One was translated and one was not.  This was causing the crash that you were
seeing in the Python code.

I have fixed this in CVS by removing the partial French translations.  However,
someone needs to come back and fully translate fr.po to make sure that things
are translated.  Most of the menus are not currently translated.

Comment 2 Brent Fox 2003-05-19 21:33:20 UTC
*** Bug 88251 has been marked as a duplicate of this bug. ***

Comment 3 Brent Fox 2003-05-19 21:39:59 UTC
*** Bug 90947 has been marked as a duplicate of this bug. ***