Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 85868

Summary: rpm --rebuilddb db4 error(11) issue after installing phoebe
Product: [Retired] Red Hat Public Beta Reporter: Amoor Avakian <unamour>
Component: rpmAssignee: Jeff Johnson <jbj>
Status: CLOSED WORKSFORME QA Contact: Mike McLean <mikem>
Severity: high Docs Contact:
Priority: high    
Version: phoebeCC: unamour
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-03-10 16:17:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Amoor Avakian 2003-03-09 22:38:15 UTC
Description of problem:

I had RH 8, then i upgraded to Phoebe, the rpm database started to give
problems, i had to follow the instructions on this website :
http://www.rpm.org/hintskinks/repairdb/ but that did not work as when i ran "rpm
--rebuilddb" command i got this error :

error: db4 error(11) from dbenv->open: Resource temporarily unavailable

The same error is thrown by Ximian Red-Carpet AFTER the upgrade to Phoebe,
before it worked fine.  Thanks.

Comment 1 Jeff Johnson 2003-03-10 16:17:32 UTC
rpm-4.2 uses posix mutexes for locking, so you need to
remove the database environment
    rm -f /var/lib/rpm/__db*

Red Carpet uses librpm404, which does not use posix mutexes,
so you are going to have interoperability problems until
Red Carpet starts to use rpm-4.1 or later.