Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 85833

Summary: Anaconda handles missing packages poorly
Product: [Retired] Red Hat Public Beta Reporter: Zenon Panoussis <redhatbugs>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED WONTFIX QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: phoebe   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-03-11 17:33:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Zenon Panoussis 2003-03-08 20:19:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210

Description of problem:
Normally, if anaconda doesn't find an rpm that is selected for installation, or
finds one that is corrupted, it returns an error message with the alternatives
"cancel" and "try again". 

On errors on mtr-gtk-0.52-2.i386.rpm, lynx-2.8.5.11.i386.rpm and
ncftp-3.1.5-4.i386.rpm this behavious fails. Anaconda reports "fatal error" and
only offers the option to reboot. 

In my case, these files (and many others) were indeed corrupted and they
installed fine when I replaced them with good copies. The problem is not in the
packages themselves, but in anaconda's error handling: on these particular files
it does not offer the option to try again. Result: the installation has to be
started all over from scratch and annoyance reaches red level after the third time. 


Version-Release number of selected component (if applicable):
phoebe-3

How reproducible:
Didn't try

Steps to Reproduce:
1. Ruin one of the packages in question
2. Try an installation that includes that package.
    

Additional info:

Comment 1 Zenon Panoussis 2003-03-08 20:40:33 UTC
Note: Using NFS and the graphical installer.


Comment 2 Jeremy Katz 2003-03-11 17:33:46 UTC
If they're corrupted on the server and we don't find out until rpm is unpacking
them, there's unfortunately not much we can do :(

Comment 3 Zenon Panoussis 2003-03-12 00:41:24 UTC
Well yes, there is: make sure that anaconda asks instead of just crashing. It
does that already on other corrupt packages, so why not on these three too? To
me, it looks like a forgotten if/then error check, nothing much more.