Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 85768

Summary: Configtool crash after use of admin dialog
Product: [Retired] eCos Reporter: John Dallaway <jld>
Component: ConfigToolAssignee: John Dallaway <jld>
Status: CLOSED WORKSFORME QA Contact: John Dallaway <jld>
Severity: medium Docs Contact:
Priority: medium    
Version: 2.0 beta 1CC: jifl-bugzilla
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-04-03 15:44:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description John Dallaway 2003-03-07 13:29:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
The eCos Configuration Tool on Linux will crash when the admin dialog is dismissed. This will happen on the second occasion the admin dialog is dismissed even if no packages are added or removed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Invoke the Administration dialog box
2. Dismiss it
3. Repeat steps 1 and 2.
    

Actual Results:  The configtool window will vanish.

Expected Results:  The repository should be reloaded.

Additional info:

eCos Configuration Tool 2.12.net (eCos 2.0b1). Linux only. To workaround, use ecosadmin.tcl directly to add/remove packages.

Comment 1 John Dallaway 2003-04-03 15:44:07 UTC
Unable to reproduce with latest configtool CVS sources built against wxWindows 
2.4.0.