Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 85597

Summary: Configtool internal doc viewer issues
Product: [Retired] eCos Reporter: John Dallaway <jld>
Component: ConfigToolAssignee: John Dallaway <jld>
Status: CLOSED WONTFIX QA Contact: John Dallaway <jld>
Severity: low Docs Contact:
Priority: medium    
Version: 2.0 beta 1CC: jifl-bugzilla
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-06-20 16:20:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description John Dallaway 2003-03-04 20:54:29 UTC
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux) 
 
Description of problem: 
The 'regenerate help index' feature generate two files (eCos.hhc and eCos.hhp) 
in the root of the eCos installation. These files do not appear to be used. 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Select 'Regenerate Help Index' from the 'Tools' menu. 
2. 
3. 
     
 
Actual Results:  eCos.hhp and eCos.hhc are generated in the directory 
containing the 
'packages' directory. 
 
Expected Results:  The configtool should generate a master index document. 
 
Additional info: 
 
eCos Configuration Tool 2.12.net (eCos 2.0b1)

Comment 1 Jonathan Larmour 2003-03-05 16:05:34 UTC
It's used for the config tool's internal viewer. Go into View->settings and
change that to be the default. Although it mostly works, that viewer needs
updating a little for the recent doc changes.

Actually making it the default would solve a lot of problems.

Comment 2 John Dallaway 2003-05-05 14:16:32 UTC
I have tweaked the configtool internal doc viewer to work with the latest eCos 
HTML doc set. However, the Linux build will cause a SYSSEGV when parsing the 
eCos reference guide. I have worked around this by avoiding parsing of this 
doc under Linux. Since this issue is unresolved, I have not made the internal 
viewer the default one for the time being. 
 
There have also been reported problems with the use of anchors to external web 
sites in the internal viewer. 

Comment 3 Alex Schuilenburg 2003-06-20 16:20:18 UTC
This bug has moved to http://bugs.ecos.sourceware.org/show_bug.cgi?id=85597