Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 85589

Summary: XFree86-4.3.0-Radeon grainy windows
Product: [Retired] Red Hat Linux Reporter: Sammy <umar>
Component: XFree86Assignee: Owen Taylor <otaylor>
Status: CLOSED WORKSFORME QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: mharris, nalin, than
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-08-29 15:25:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Log file
none
Config file none

Description Sammy 2003-03-04 19:22:58 UTC
I just got a new DELL 2000FP flat panel monitor and a Radeon VE/7000 (32MB) 
card. I have the current rawhide, kernel 2.4.20-2.54 and XFree86-4.3.0-2 
(mharris). I got everything to work (analog connection) fine except shell 
windows leave grains of vertical short bars on the screen after scrolling. Any 
known fix for this? Thanks

Comment 1 Sammy 2003-03-05 17:28:57 UTC
Created attachment 90480 [details]
Log file

Comment 2 Sammy 2003-03-05 17:29:45 UTC
Created attachment 90481 [details]
Config file

Comment 3 Mike A. Harris 2003-03-07 21:46:22 UTC
This isn't a Radeon driver bug (however it is certainly reasonable to
have assumed it might be).  It is either an application font rendering
bug, or an Xft or Xrender bug.  It's reported in another bug report
somewhere by me actually against gnome-terminal or kdebase (konsole).

It only shows up with high-bit i18n text when scrolling in konsole and
gnome-terminal.  Keith Packard believes it to be an application bug.

I haven't debugged it personally, as I've assumed it is an app bug like
Keith postulates and am awaiting for someone to troubleshoot g-t or
konsole, however I may take a stab at it sometime myself.

Comment 4 Mike A. Harris 2003-04-21 14:35:00 UTC
Keith believed this to be an application bug when I spoke with him
before, where the font extends outside the bounding box or somesuch.

Comment 5 Owen Taylor 2003-04-21 14:51:18 UTC
So, this:

 A) Occurs for both gnome-terminal and konsole
 B) Only shows up with the Radeon driver

? If that's the case, it's almost certainly *not* an application
bug. A screenshot would help me say for certain. 


Comment 6 Sammy 2003-04-21 15:08:08 UTC
I don't know whether it is application or not but it was there until two days ago. After 
my upgrades to: 
 
1. KDE_3.1_BRANCH and KDE_3_1_1_BRANCH changes merged in all rpms. 
2. XFree84 4_3_99_2 snapshot for April 10 applied to xf86 rpms. 
3. Latest rawhide (4-21-2003) 
 
I can no longer reproduce it to give you a screenshot. I guess this is a good thing! 

Comment 7 Mike A. Harris 2003-04-21 15:51:23 UTC
There's a screenshot in another bug report, but I don't have the ID.  It's
against vte IIRC, or konsole.  It isn't Radeon specific (or I'd assume it
to be a Radeon driver bug).  It only occurs in some applications that use
Xft.  I've only seen it in gnome-term and konsole personally, and it can
be reproduced by catting a text file containing international high-bit
text to the screen.  When it scrolls, the fonts leave droppings on the screen.

If newer KDE fixes it for konsole, and assuming the problem is indeed app
specific, I assume konsole has been fixed now.  I haven't tested any recent
stuff to see though.

Comment 8 Sammy 2003-04-21 16:00:30 UTC
That is the correct description of the problem. I also suspected konsole. Initial 
kde-3.1.1 did not fix the problem, so the latest branch fixes should be included 
in. It is time for rawhide to do this. 

Comment 9 Mike A. Harris 2003-04-21 16:21:57 UTC
Reproduced just now in gnome-terminal on Mach64 (Rage IIC) in RHL 9

Comment 10 Mike A. Harris 2003-04-21 16:22:46 UTC
I used the following to reproduce:

cat $(locate .desktop | head)

Then scrolled up and down in the terminal

Comment 11 Owen Taylor 2003-04-21 16:24:19 UTC
Can you attach a screenshot of this? I can't reproduce offhand. (Though
I may have different desktop files, and different fonts.)


Comment 12 Mike A. Harris 2003-04-21 16:31:39 UTC
Found the other bug report:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=83530

There are 2 screenshots attached to it, along with claim of reproduceability
on Matrox and Nvidia hardware as well.

Comment 13 Owen Taylor 2003-04-21 16:40:39 UTC
The theory described - "it's an app bug" - only makese sense if the
terminal:

 A) Redraws instead of scrolling
 B) Optimizes out and doesn't redraw character that it thinks were
    blank and stay blank.

Does this sound reasonable to you, Nalin, with your knowledge of
VTE's internals?



Comment 14 Mike A. Harris 2003-05-26 14:54:14 UTC
ping nalin

Comment 15 Owen Taylor 2003-08-29 15:25:59 UTC
The screenshots on the other bug are of konsole, which is sort of irrelevant
to what gnome-terminal does. I haven't seen any problems of this nature
in using various versions of gnome-terminal intensively. Since no
duplicates have been reported of this, I'm going to guess it's a very
rare problem, if it occurs at all with current versions of gnome-terminal/
XFree86.

Closing WORKSFORME.


Comment 16 Mike A. Harris 2003-08-30 10:27:25 UTC
I'm able to reproduce it in both gnome-terminal and konsole, but only
in RHL 9 stock XFree86.  I haven't tried to test it in our current
beta release yet, nor with the latest XFree86 from rawhide rebuilt
and used in RHL 9.

I wont be able to test wether or not this still occurs for a while yet,
however if anyone can reproduce this in the current beta, feel free to
reopen the bug.