Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 85467

Summary: Unable to change RHN account password.
Product: Red Hat Network Reporter: steven.knight
Component: RHN/Web SiteAssignee: Mike Orazi <morazi>
Status: CLOSED WORKSFORME QA Contact: Red Hat Satellite QA List <satellite-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: RHN StableCC: rhn-bugs
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-02-13 20:13:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description steven.knight 2003-03-03 06:40:14 UTC
Description of problem: Unable to change password.


Version-Release number of selected component (if applicable):
  Current version of RHN's website.



How reproducible:

Change password.


Steps to Reproduce:
1. Enter valid password and password Confirmation on the "Account Details" form.

2. Upon clicking "Update" the password revert to the previous passwords.
    
Actual results:  I am unable to change my RHN account password.  I've
try several passwords which are valid on RH Linux.



Expected results:


Additional info:

Comment 1 Chip Turner 2003-03-03 16:40:56 UTC
what browser are you using?  can you change any other fields on that page, or is
password the only one misbehaving?  do you get an error message?

Comment 2 steven.knight 2003-03-03 17:17:12 UTC
Browser:  I've tried mozilla-1.3b, galeon-1.3.2 ( beta ).  And thinking that it
was problem with the beta releases on the browser, I also downloaded:
mozilla-i686-pc-linux-gnu-1.2.1-installer.tar.gz  ( and installed just the
browser ).

and in all three cases I was unable to change the password.  Let me know if
you'd like to use the mozilla RPMS which ship with phoebe3.  galeon-1.3.2 is the
RPM provided by the galeon team and mozilla is from the RedHat8x_RPMS from
mozilla.org.

Other fields:  Using all browsers I was able to change: First Name, Last Name
and Title.

ErrorMessage:  None.

I enter the password twice.  Click update and the old password returns.  

Comment 3 steven.knight 2003-03-03 20:40:53 UTC
A quick update.  I also tried to change the password on a RedHat 8.0 using
mozilla-1.0.1 and galeon 1.2.6 both are RedHat RPMS.



Comment 4 steven.knight 2003-03-03 20:46:23 UTC
Addition to comment #3, I was unable to change the password using either galeon
o r mozilla.