Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 85465

Summary: neat utility fails attempting to edit hardware for eth0
Product: [Retired] Red Hat Linux Reporter: David Brusowankin <david>
Component: redhat-config-networkAssignee: Harald Hoyer <harald>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:52:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description David Brusowankin 2003-03-03 06:16:57 UTC
Description of problem:

When using neat, attempting to edit the hardware (intel EhterExpress Pro 100B)
tab causes traceback

Version-Release number of selected component (if applicable):


How reproducible:
Take an IBM T22 laptop, run the "neat" utility and try to edit the ethernet device.

Steps to Reproduce:
1.
2.
3.
    
Actual results:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File
"/home/dobey/ximian-desktop/pygtk/dest/usr/lib/python1.5/site-packages/gtk.py",
line 2676, in mainloop
    _gtk.gtk_main()
  File
"/home/dobey/ximian-desktop/pygtk/dest/usr/lib/python1.5/site-packages/libglade.py",
line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 1248, in on_hardwareEditButton_clicked
    self.showHardwareDialog(type, true)
  File "/usr/sbin/neat", line 1269, in showHardwareDialog
    dialog = ethernetHardwareDialog(hw)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernethardware.py",
line 75, in __init__
    self.setup()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernethardware.py",
line 135, in setup
    list.append(modInfo[i]['description'])
KeyError: description

Expected results:

I don't know. I have never been successful

Additional info:

Comment 1 Harald Hoyer 2003-03-10 14:05:54 UTC

*** This bug has been marked as a duplicate of 76226 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:03 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.