Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 85357

Summary: redhat-config-users does not create MD5 password
Product: [Retired] Red Hat Linux Reporter: Jim Shanks <jshanks>
Component: redhat-config-usersAssignee: Brent Fox <bfox>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-05-22 20:58:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jim Shanks 2003-02-28 15:49:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
Creating a new user with redhat-config-users produces an encrypted password 
in /etc/shadow but not an MD5 encrypted password.  Passwords later changed with 
the passwd command produce a password as per system defaults.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  add a new user <username> with redhat-config-users and cat /etc/shadow | 
grep <username>
2.  change password to the same password with passwd <username> and 
cat /etc/shadow | grep <username>
3.  compare the results
    

Actual Results:  Original password will be encrypted as a 13 character string.  
Password created with passwd will be a 34 character MD5 string begining with $1
$.

Expected Results:  redhat-config-users should create an encrypted password 
identical to passwd as per the system settings.

Additional info:

My oldest system has 7.3 installed.  Same behavior there.

Comment 1 Brent Fox 2003-04-03 20:26:17 UTC
The only way I can reproduce this is if I turn off "Use MD5 passwords" with
authconfig.  In which case, redhat-config-users is doing the right thing to not
make MD5 encrypted passwords.  However, on my test machine, 'passwd' does not
make an MD5 password if MD5 passwords are disabled.

Once I re-enable MD5 passwords with authconfig, both redhat-config-users and
passwd start making MD5 passwords.

I don't seem to be able to reproduce your problem.

Comment 2 Brent Fox 2003-05-22 20:58:07 UTC
Closing as 'worksforme'.  The program seems to be working properly on my test
machines.