Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 85339

Summary: named crashes under heavy tcp load
Product: [Retired] Red Hat Linux Reporter: Pavel Urban <fc-bugzilla>
Component: bindAssignee: Daniel Walsh <dwalsh>
Status: CLOSED RAWHIDE QA Contact: Ben Levenson <benl>
Severity: high Docs Contact:
Priority: medium    
Version: 7.3   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-07-08 13:24:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Pavel Urban 2003-02-28 08:43:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2) Gecko/20021216

Description of problem:
This is well-known bind bug. When you have broken/misconfigured client who sends
too many tcp queries, you end up like this:

Feb 28 01:00:53.826 client 80.188.162.170#3859: no more TCP clients: quota reached
Feb 28 01:00:53.829 client 80.188.162.170#3860: no more TCP clients: quota reached
Feb 28 01:00:53.831 client 80.188.162.170#3861: no more TCP clients: quota reached
Feb 28 01:00:53.832 client 80.188.162.170#3863: no more TCP clients: quota reached
Feb 28 01:00:54.720 quota.c:68: INSIST(p != ((void *)0) && *p == ((void *)0)) failed
Feb 28 01:00:54.720 exiting (due to assertion failure)

See http://marc.theaimsgroup.com/?l=bind9-users&m=104326843802099&w=2 for
further info. This has been fixed in 9.2.2rc1, can you incorporate this fix, please?

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

Comment 1 Daniel Walsh 2003-03-04 15:14:28 UTC
Latest bind is available on rawhide 9.2.2.