Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 85338

Summary: redhat-config-users hangs when deleting user
Product: [Retired] Red Hat Linux Reporter: Martin Faltesek <martin>
Component: redhat-config-usersAssignee: Brent Fox <bfox>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:52:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Martin Faltesek 2003-02-28 08:32:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210

Description of problem:
When I attempt to delete a user, this (quite nice) tool hangs. 
After I kill it and restart it, it had indeed deleted
the user from /etc/passwd and /etc/shadow, but had not
removed the home dir despite that option being selected.

I have a pretty basic home setup without any external
network services (no nis, etc).




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create user
2. try to delete user, click on 'ok' to remove user's dir.
    

Actual Results:  removed user from /etc/passwd and /etc/shadow, but gui hangs
and doesn't remove user dir.

Expected Results:  no hang.  remove user dir.

Additional info:

Comment 1 Brent Fox 2003-04-03 21:42:56 UTC
Try running the tool from the command line.  Then do the same set of steps and
see if any debug information is printed out on the command line when the program
hangs.  Any info there?

Comment 2 Martin Faltesek 2003-04-07 18:23:13 UTC
here's the info I collected by running on the command line:


desktop $ Traceback (most recent call last):
  File "/usr/share/redhat-config-users/mainWindow.py", line 644, in
on_delete_activate
    rmrf (homeDir + '/' + file)
NameError: global name 'rmrf' is not defined

Comment 3 Brent Fox 2003-05-23 05:42:05 UTC

*** This bug has been marked as a duplicate of 83341 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:52:02 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.