Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 85208

Summary: Cannot install on a Via Mini-ITX system EPIA 800 C3
Product: [Retired] Red Hat Linux Reporter: Mike Plummer <mike.plummer>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: amiri1, homme
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-06-05 11:27:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mike Plummer 2003-02-26 17:31:15 UTC
Description of problem: Cannot even install Phoebe on a VIA Mini-ITX EPIA 800 
C3. Have been using Redhat 8.0 successfully on the same platform 


Version-Release number of selected component (if applicable):

V 8.094
How reproducible:
Totally and on more than one machine

Steps to Reproduce:
1. Insert Installation CD and start graphical install/upgrade
2.
3.
    
Actual results:
Immediate paging fault and kernel panic

Expected results:
Installation system booted

Additional info:

Comment 1 Alan Cox 2003-02-26 18:07:41 UTC
Can you provide the actual panic message.  I've installed the beta on three
different VIA C3 based systens, including two EPIA-M boards one with a fanless
600MHz and one with a fanned 900Mhz CPU

Does this same CD image work on a different PC ?


Comment 2 Paul Coleman 2003-02-28 10:06:56 UTC
I have the same board running rawhide. Shortly after kernal-2.4.20-2.30.i586 the
new kernals would not boot. This is from my notes as I have not captured the
entire panic message. 

unable to handle kernal paging request at virtual address C0000000 ...
oops 0003 ...
do_test_wp_bit C0115878 ... tried to kill idle task ...

Comment 3 Mike Plummer 2003-02-28 11:55:42 UTC
From Mike Plummer

I got the same message as Paul Coleman. The board uses a fanned 800 C3

Happens after "Checking if processor homours WP bit even in supervisor mode"

Kernel panic code
88 0a 31 c0 c3 56 53 bb 00 a0 28 c0 81 fb 00 40 2a c0 73 4f

Award BIOS on card

The CD does boot and install correctly on a P3 400 and I have installed other 
versions of Linux including RH 8.0 on the MIni-ITX machine without trouble 

Comment 4 Alan Cox 2003-03-09 00:48:50 UTC
Double checking, I'd assumed I used 8.0.94 on my epia. Now I indeed find I used
8.0.93 and see the problem after that in the later releases.



Comment 5 Zenon Panoussis 2003-03-12 00:13:38 UTC
me too! :(

BTW, there's a dupe at #85908.

For what it might be worth:

Checking if this processor honours the WP bit even in supervisor mode...
<1>Unable to handle kernel paging request at virtual address c0000000
 printing eip:
c01143e7
*pde = 00001063
*pte = 00000025
Oops: 0003
CPU:    0
EIP:    0060:[<c01143e7>]     Not tainted
EFLAGS: 00010206

EIP is at (2.4.20-2.BOOT)
eax: 00000001   ebx: 00001000   ecx: 00000001   edx: c0000000
esi: 00000163   edi: c0105000   ebp: 0004e000   esp: c0289fd8
ds: 0068   es: 0068  ss: 0068
Process swapper (pid 0, stackpage=c0289000)
Stack: c028ff7a c0000000 00000160 000004bd c02902b5 00000000 00059800 c028a601
       c02a6f00 c010018c
Call Trace:

Code 88 0a 31 c0 c3 56 53 bb 00 a0 28 c0 81 fb 00 40 2a c0 73 4f
 <0>Kernel panic: Attempted to kill the idlke task!
In idle task - not syncing


Comment 6 Michael K. Johnson 2003-03-12 17:24:06 UTC
*** Bug 85908 has been marked as a duplicate of this bug. ***

Comment 7 Michael K. Johnson 2003-03-12 17:36:55 UTC
We have tracked this one down, thanks for the bug reports!
Just remove patch 900 (linux-2.4.20-oopsmeharder.patch) which was
intended to (and did...) catch more error cases, but also broke
this test.  The test is simply not done on more modern CPU designs,
so the newest C3s such as those included with the VIA EPIA M10000
are not affected.

Comment 8 Zenon Panoussis 2003-03-13 03:19:57 UTC
Confirmed. Replacing the distribution vmlinuz with a non-patch900-BOOT kernel
solves the problem. Thanks!

I made a bootdisk.img with the corrected kernel (rather useless on my floppyless
machine, had to put it on a boot CD). Next question: is it worthwhile for me to
make and publish a complete phoebe-epia-disc1.iso , or are you guys going to fix
this in the current phoebe-3 distribution? 

The EPIA bootdisk.img will be at http://www.provocation.net/bootdisk.img in an
hour or so. 

Only now I notice that the original bug report was about the 800. Mine is an
M9000 having the same problem.

Z


Comment 9 Zenon Panoussis 2003-03-15 21:51:43 UTC
A corrected bootable CD1 is available at http://www.provocation.net/epia.html . 
To install Phoebe-3 you still need CD2 and CD3 from a suitable Redhat mirror. 

Comment 10 Mehrdad 2004-08-06 19:18:39 UTC
Can't download from www.provocation.net


Comment 11 Mehrdad 2004-08-07 08:24:01 UTC
Hi,
I have the same Problem And I don't know how I can remove (linux-
2.4.20-oopsmeharder.patch) and solve the problem .The Links 
http://www.provocation.net/bootdisk.img and other Links no longer 
works.
Please Help.