Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 85105

Summary: /etc/init.d/pcmcia returns wrong exit code
Product: [Retired] Red Hat Linux Reporter: Cengiz Alaettinoglu <calaettinoglu>
Component: kernel-pcmcia-csAssignee: Dave Jones <davej>
Status: CLOSED WONTFIX QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: pfrields
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-11-25 08:30:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Cengiz Alaettinoglu 2003-02-25 19:08:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
the last line
case $0 in *rc.pcmcia) exit $EXITCODE ;; esac

ought to be
case $0 in *pcmcia) exit $EXITCODE ;; esac

since there is no rc. prefix in the name of the scripts in /etc/init.d. This
creates problems if for example pcmcia is added to /etc/sysconfig/apmd's
RESTORESERVICES="named pcmcia"

Cengiz


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. add RESTORESERVICES="named pcmcia" to /etc/sysconfig/apmd
2. /etc/init.d/apmd restart
3. /etc/init.d/pcmcia stop
4. suspend the laptop and then resume
    

Actual Results:  pcmcia is turned on on resume.

Expected Results:  pcmcia should be off since it was not on before going to suspend.

Additional info:

removing rc. prefix from the last line of /etc/init.d/pcmcia solves this problem.