Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 85011

Summary: GUI creates route files that boot scripts can't see if interface nicknames used
Product: [Retired] Red Hat Linux Reporter: Rod Marten <rod.marten>
Component: redhat-config-networkAssignee: Harald Hoyer <harald>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: mitr
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-08-11 14:10:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 81720    

Description Rod Marten 2003-02-24 21:26:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
When using the redhat-config-network gui, the files creates route files with the
nickname (vs ethX).  However, ifup-routes relies on the ethX name to find the
interface routes.  As a result interface specific static routes will not be read
on boot.

For example:
My system has eth1 nicknamed InternalInterface.  Interface specific routes are
listed in /etc/sysconfig/networking/devices/InternalInterface.routes. 
ifup-routes looks for eth1.routes and doesn't see InternalInterface.routes.

This is especially troublesome if you create an interface with static routes
then nickname the interface.  Static routes will always be set to the initial
ones no matter how much you try to change them with the GUI due to the fact that
the new route table config isn't loaded

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a new ethernet interface
2. Give the interface a nickname
3. Set some static routes on the interface
4. Reboot
5. Check routes with route command
    

Actual Results:  Interface specific static routes will not appear in the route table

Expected Results:  Interface spedific routes will appear in the route table

Additional info:

Copying the /etc/sysconfig/networking/devices/nickname.route file to
/etc/sysconfig/networking/devices/ethX.route will work as a workaround.

Comment 2 Harald Hoyer 2003-03-31 15:48:31 UTC
fixed in CVS

Comment 3 Harald Hoyer 2003-08-11 14:10:19 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-183.html