Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 84762

Summary: SCSI bus reset errors when attempting to burn a CD
Product: [Retired] Red Hat Linux Reporter: tom georgoulias <tomg>
Component: cdrtoolsAssignee: Harald Hoyer <harald>
Status: CLOSED DUPLICATE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 9CC: elwoo, gczarcinski
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:51:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description tom georgoulias 2003-02-21 02:14:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
When using xcdroast to try and burn a CD, the burn fails for the following error:
"Input/output error. send opc: scsi sendcmd: no error"

Version-Release number of selected component (if applicable):
cdrecord-2.0-4

How reproducible:
Always

Steps to Reproduce:
1. Start xcdroast, select files to be burned, etc.
2. Push "Master & Write on the fly" button

    

Actual Results:  Got a SCSI bus reset error, no burned CD.

Expected Results:  cdrecord should begin burning the CD

Additional info:

This install of phoebe was an upgrade from a default RH 8.0 install with all
errata applied.  The media, files selected for backup, CDROM, and everything
worked just fine under 8.0.

[tomg@gemini tomg]$ cat /etc/redhat-release
Red Hat Linux release 8.0.94 (Phoebe)

[tomg@gemini tomg]$ rpm -q xcdroast
xcdroast-0.98a13-4
[tomg@gemini tomg]$ rpm -q kernel
kernel-2.4.20-2.48

[root@gemini root]# hdparm /dev/hdc
 
/dev/hdc:
 HDIO_GET_MULTCOUNT failed: Invalid argument
 IO_support   =  0 (default 16-bit)
 unmaskirq    =  0 (off)
 using_dma    =  0 (off)
 keepsettings =  0 (off)
 readonly     =  0 (off)
 BLKRAGET failed: Invalid argument
 HDIO_GETGEO failed: Invalid argument
[root@gemini root]#

cdrecord log:
Calling: /usr/lib/xcdroast-0.98/bin/xcdrwrap CDRECORD dev=0,0,0 gracetime=2
fs=4096k -v driveropts=burnfree  speed=16 -eject -pad tsize=308832s -

scsidev: '0,0,0'
scsibus: 0 target: 0 lun: 0
Linux sg driver version: 3.1.24
TOC Type: 1 = CD-ROM
Using libscg version 'schily-0.7'
Driveropts: 'burnfree'
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'PLEXTOR '
Identifikation : 'CD-R   PX-W1610A'
Revision       : '1.04'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc CD-R driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
Drive buf size : 1190112 = 1162 KB
FIFO size      : 4194304 = 4096 KB
Track 01: data   603 MB         padsize:   30 KB
Total size:      692 MB (68:37.98) = 308849 sectors
Lout start:      693 MB (68:39/74) = 308849 sectors
Current Secsize: 2048
ATIP info from disk:
Indicated writing power: 6
Is not unrestricted
Is not erasable
Disk sub type: Medium Type C, low Beta category (C-) (6)
ATIP start of lead in:  -11231 (97:32/19)
ATIP start of lead out: 359849 (79:59/74)
Disk type:    Short strategy type (Phthalocyanine or similar)
Manuf. index: 27
Manufacturer: Prodisc Technology Inc.
Blocks total: 359849 Blocks current: 359849 Blocks remaining: 51000
Starting to write CD/DVD at speed 16 in real TAO mode for single session.
Waiting for reader process to fill input buffer ... input buffer ready.
BURN-Free is ON.
Performing OPC...
cdrecord: Input/output error. send opc: scsi sendcmd: no error
CDB:  54 01 00 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 06 00 00 00 00 0A 00 00 00 00 29 00 00 00
Sense Key: 0x6 Unit Attention, Segment 0
Sense Code: 0x29 Qual 0x00 (power on, reset, or bus device reset occurred) Fru 0x0
Sense flags: Blk 0 (not valid) 
cmd finished after 30.190s timeout 60s
cdrecord: OPC failed.
Writing  time:   35.998s
cdrecord: fifo had 64 puts and 0 gets.
cdrecord: fifo was 0 times empty and 0 times full, min fill was 100%.

the following lines in /var/log/messages are repeated 10-12 times:

Feb 20 19:53:57 gemini kernel: scsi : aborting command due to timeout : pid
56996, scsi0, channel 0, id 0, lun 0 Test Unit Ready 00 00 00 00 00
Feb 20 19:53:57 gemini kernel: SCSI host 0 abort (pid 56996) timed out - resetting
Feb 20 19:53:57 gemini kernel: SCSI bus is being reset for host 0 channel 0.
Feb 20 19:53:57 gemini kernel: hdc: ATAPI reset complete

Comment 1 tom georgoulias 2003-02-21 05:18:06 UTC
Did some more research and found that this bug is related to the kernel and has
already been reported as #84160.  I added my info there since I figured this one
would be closed.

Comment 2 Elton Woo 2003-02-22 07:13:48 UTC
I can concur that I have been having various and repeatable problems when
_trying to burn_ a CD. I use either Xcdroast, Gtoaster or cdrecord from the
console. I have "successfully" burnt
the 3 ISO images of Phoebe 3 (RH 8.0.9.4) but I have not installed it _pending_
the ability to
back up my stuff to CD (which I seem to be unsuccessful in doing, at present).

Currently, the system is still Phoebe 2 (RH 8.0.9.3) with the latest rawhide
packages installed
(Feb 20), CPU AMD Athlon Thunderbird 1.0G. The following kernel pagkages are
installed:
]$ rpm -q -a | grep kernel
kernel-doc-2.4.20-2.50
kernel-2.4.20-2.51
kernel-utils-2.4-8.29
kernel-source-2.4.20-2.50
    ... as of this writing ...(Feb. 22nd -00h:52 EST)

Comment 3 Elton Woo 2003-02-22 08:29:32 UTC
recent output when attempting to *blank* a CDRW from the console:
 root]# cdrecord -blank=fast -force -dev=0,0,0 speed=4
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J?rg Schilling
scsidev: '0,0,0'
scsibus: 0 target: 0 lun: 0
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.7'
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'TEAC    '
Identifikation : 'CD-W516EB       '
Revision       : '1.0B'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc CD-R driver (mmc_cdr).
Driver flags   : MMC SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P RAW/R96R
cdrecord: Input/output error. blank unit: scsi sendcmd: no error
CDB:  A1 01 00 00 00 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 06 00 00 00 00 0A 00 00 00 00 29 00 00 00
Sense Key: 0x6 Unit Attention, Segment 0
Sense Code: 0x29 Qual 0x00 (power on, reset, or bus device reset occurred) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 953.049s timeout 9600s


Comment 4 Gene Czarcinski 2003-02-22 17:35:53 UTC
Related (perhaps a dup of)
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=84160

Comment 5 Harald Hoyer 2003-02-24 10:56:10 UTC

*** This bug has been marked as a duplicate of 84160 ***

Comment 6 Elton Woo 2003-03-13 02:46:12 UTC
By editing '/etc/modules.conf' and adding the 
following line: 
options ide-cd dma=1 
I am now able to successfully burn/erase CDRW disks without the reset errors 
or timeouts near the end of 'fixating'.  
This is with Phoebe 3rd beta/ RH 8.0.94, with these kernels in use: 
kernel-2.4.20-2.48 (default) 
kernel-2.4.20-2.54 (from rawhide) 
IMVHO, turning *off* DMA by default, probably has been the main contributor 
of my problems with CD's. Magicdev had been removed, as per advice 
on the Phoebe mailing list, but until I amended my modules.conf as above, 
I still had consistent failures. 
 

Comment 7 Red Hat Bugzilla 2006-02-21 18:51:55 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.