Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 84747

Summary: kickstart configurator redhat-config-kickstart won't delete partition entries
Product: [Retired] Red Hat Linux Reporter: Karsten Wade <kwade>
Component: redhat-config-kickstartAssignee: Brent Fox <bfox>
Status: CLOSED RAWHIDE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-05-25 14:30:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Karsten Wade 2003-02-20 23:41:10 UTC
Description of problem:

If you make more than one entry in the partition tab of redhat-config-kickstart,
the application will not let you delete any of the entries.


Version-Release number of selected component (if applicable):

redhat-config-kickstart-2.3.3-3


How reproducible:
Always

Steps to Reproduce:
1. Go to the partition tab/section, with defaults of "clear MBR", "remove all
existing partitions" and "initialize the disk label" 
2. Add more than one partition of any type.
3. Select a partition, causing the Delete button to become active, and try to
delete the partition.      

Actual results:
Added and selected partitions do not delete.

Expected results:
Any selected partition should be able to be deleted

Additional info:
Of course, one can just edit the final ks.cfg file, but I don't think that was
the point of the partitioning section. :)

Comment 1 Brent Fox 2003-02-21 20:37:47 UTC
Did you open an exising kickstart file or were you creating one from scratch?

Comment 2 Karsten Wade 2003-02-21 20:43:37 UTC
I was creating a new one from scratch.

I don't see an obvious way to work with an existing one.  Is there a file open
dialog somewhere?  I also tried 'redhat-config-kickstart ks.cfg' from the
command line, which didn't open the kickstart file.

Comment 3 Brent Fox 2003-02-22 00:21:21 UTC
No, but there is in Phoebe.  For a moment I thought you were running the beta.

Comment 4 Brent Fox 2003-02-24 22:41:12 UTC
Should be fixed in redhat-config-kickstart-2.3.6-4

Comment 5 Brent Fox 2003-05-25 14:30:26 UTC
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.