Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 84678

Summary: koffice does not function without kdebase installed, but it does not require it
Product: [Retired] Red Hat Linux Reporter: Matt Wilson <msw>
Component: kofficeAssignee: Ngo Than <than>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: jspaleta, mitr, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-06-02 10:36:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79578    

Description Matt Wilson 2003-02-20 08:06:23 UTC
Description of problem:
'koffice' does not run even if its package dependencies are resolved and kdebase
isn't installed.

Version-Release number of selected component (if applicable):
koffice-1.2.1-3

How reproducible:
100%

Steps to Reproduce:
1. install Personal Desktop, do not select KDE, ensure kdebase isn't installed
2. install koffice
3. log in to GNOME, try to start kword
4. install kdebase.  verify kword starts
    
Actual results:
kword exits with return code 1

Expected results:
kword starts

Comment 1 Warren Togami 2003-02-20 10:49:21 UTC
I'm not sure this is the case.  I just did a fresh "Everything" install of
Phoebe3 , logged directly into Gnome as "warren" and tried KOffice.  It fails
completely and I do have kdebase-3.1-7.


Comment 2 Jef Spaleta 2003-02-20 18:32:18 UTC
I have one system with everything installed that works perfectly.
I just did a second system upgraded from rh8 with kde installed and running
koffice apps under gnome fails...fails from menu...fails from terminal.
kdebase is installed on both systems.

On the system where things are not working
I do notice that the koffice apps like kword, start kinit but then kinit dies in
less than a minute, after the koffice app returns on the commandline.  I not
sure if there is some logging information I can get at to see what is something
is going wrong with kinit.
ps -ax right after kchart on a terminal exits:

3753 ?        S      0:00 kdeinit: Running...
3756 ?        S      0:00 kdeinit: dcopserver --nosid --suicide
3759 ?        S      0:00 kdeinit: klauncher
3761 ?        S      0:00 kdeinit: kded

but in less than a minute thats gone.

and as far as I can tell this is only affect the koffice apps...all the other
kwhatever executables ive tried seem to work...or atleast actually pop up
windows...including noatun.

Comment 3 Ngo Than 2003-02-21 14:24:24 UTC
i have made both a fresh install and a upgrade from beta. It works for me if
kdebase is installed.

It's very difficult to fix a bug, which i cannot reproduce it on my machine:-(


Comment 4 Jef Spaleta 2003-02-21 14:38:52 UTC
I agree...this is a head scratcher. so far the only box I have that has this
problem is the box I upgraded from redhat 8.0. A fresh install, and an an
upgrade from 8.0.93 aren't causing a problem for me.  Now, it could clearly be
something specific I've done on the redhat 8.0 box before i upgraded to
beta3...but it seems really odd that the person who original mentioned this bug
on the phoebe mailinglist, did a fresh install and is seeing this problem. I
wish I had another box i could duplicate the problem install senario on
myself...but i don't.



Comment 5 Ngo Than 2003-06-02 10:36:01 UTC
i close this bug, because it works for me if kdebase is installed.
i already added requires kdebase in koffice-1.2.1-7, which is included in RHL 9

any more specific way to reproduce this ? reopen then.