Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 84490

Summary: Login is really slow
Product: [Retired] Red Hat Linux Reporter: Havoc Pennington <hp>
Component: gnome-sessionAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: alexl, brackbillbruce, jirka, mitr, wtogami
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-11-10 21:02:25 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579, 100644    

Description Havoc Pennington 2003-02-17 23:12:25 UTC
Something is chugging when logging in to gnome, perhaps 
the icon theming on the splash screen icons.

Comment 1 Havoc Pennington 2003-02-20 23:18:16 UTC
maybe just the silly locate database just after installing...

Comment 2 Warren Togami 2003-02-20 23:35:34 UTC
On LTSP when 20 users login nearly simultaneously, Phoebe stalls for quite a
while on each users login session.  top shows 99% CPU usage on gdm-binary for a
few seconds per user.

kdm and gdm in RH 7.3 didn't stall like this when users logged in...


Comment 3 Havoc Pennington 2003-02-20 23:39:52 UTC
hmm, I wonder what gdm could be up to? at least that's a lead.

I'm seeing the splash screen while it chugs, though no splash icons. 
so gnome-session is running...

Comment 4 Ray Strode [halfline] 2004-11-10 21:02:25 UTC
Hi,

This bug is quite old now.  Given the lack of activity on this report and the
likelihood that this bug has already been fixed, I am going to close it.  If you
encounter the problem discussed in this report with Fedora Core 3 or a recent
version of gdm/gnome-session, feel free to reopen.

Thanks

Comment 5 Bruce Brackbill 2008-05-11 14:12:22 UTC
Maybe I should open up a new bug, but what I'm reading here looks like what I'm
experiencing.

Booting into Fedora 9 ( up to the gnome login screen ) is very fast ( seams
faster than Fedora 8 ).

But after I enter the username and password in the Greeter it takes a LONG time
to get a fully loaded/painted desktop.  25+/- seconds on my old xp 1700, 1 gig
ram, Radeon 9000 (free video drivers) and 15+/- seconds on my xp 2800 2 gigs
ram, GeForce 7300 GT ( proprietary video drivers ).

I've installed Fedora 9 on a couple other machines and I experience the same
slowness. 

One thing that is a bit disappointing is i just upgraded my neighbors grandmas
machine from an old 700MHz PIII 350MB ram i built running Fedora Core 6 to the
xp 1700 machine (described above) running Fedora 9. I tell you... Fedora Core 6
ran fast on that old machine.  Maybe faster than Fedora 9 is running on the
newer machine.  Defiantly though, the slowness from Greeter to Full desktop
doesn't help the perception.

If this should be a new bug, please let me know and i'll copy/paste this into a
newly created bug report.

Thanks,
Bruce