Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 84426

Summary: oafd is left running after logging off
Product: [Retired] Red Hat Linux Reporter: Stephen Walton <stephen.walton>
Component: oafAssignee: Havoc Pennington <hp>
Status: CLOSED RAWHIDE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 8.0CC: chris.ricker, ddeader, ekanter, herrold, katzj
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-10-09 04:12:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Stephen Walton 2003-02-16 19:37:47 UTC
Description of problem:

After logging on and off via Gnome, oafd is left running.  This is a problem in
an environment where multiple login clients share the same home directory from a
server, because it results in an error message about one's preference files
still being in use when one logs into another machine.

Version-Release number of selected component (if applicable):

oaf-0.6.9-2

How reproducible:

Always

Steps to Reproduce:
1. Log into a machine which is in an NFS/NIS or NFS/LDAP environment in which
login directories are stored on a central machine.
2. Log off of that machine and into another one on the same machine.
    
Actual results:

A popup box appears on the second login, "Your preference files are in use on
another machine."

Expected results:

No such message.

Additional info:

I am attributing this problem to oafd since it is the one process left running
after a login/logoff sequence.

Comment 1 Havoc Pennington 2003-02-16 19:43:16 UTC
oafd is GNOME 1.4 stuff, GNOME 2 in 8.0 should not start it. Evolution may start
it if you run Evolution.

the preferences message is in fact about gconfd, but gconfd should be existing
after 2 minutes without use (which is probably why you don't notice that process
by the time you're looking for it).
http://www.gnome.org/projects/gconf/ also describes a workaround setting 
GCONF_LOCAL_LOCKS env variable.

Comment 2 Stephen Walton 2003-02-17 00:52:29 UTC
Thanks for both pieces of info.  You're correct that I'm running Evolution.  I
suppose this should be marked resolved somehow, but I'm not sure;  it isn't
exactly NOTABUG but seems to be scheduled to be fixed in Gnome 2.2 judging from
the text at the above link.

Comment 3 Havoc Pennington 2003-02-17 01:08:48 UTC
well, I'm not sure it's notabug, but probably the evolution guys are planning 
to fix it by moving to gnome 2, so it all comes out the same. you might 
search bugzilla.ximian.com, may be more info there.

Comment 4 Gerald Teschl 2003-03-06 07:51:32 UTC
I just see the same thing on all of our boxes after a fresh install of 8.0.
On every box there are about 10 oafd processes running from different users.
This is a huge mess.

Comment 5 Gerald Teschl 2003-03-06 08:09:43 UTC
Wow! I just found a box with 30 oafd processes running, using 25% of the memory.

BTW, even on a current beta system, evolution does not seem to be the only
program using oaf:

$ rpm -q --whatrequires oaf
eel-1.0.2-11
GConf-1.0.9-10
oaf-devel-0.6.10-5
bonobo-1.0.22-4
gnome-vfs-1.0.5-13
bonobo-conf-0.16-5
evolution-1.2.2-1


Comment 6 Havoc Pennington 2003-03-06 14:52:13 UTC
those other packages are all libraries, evolution is the only app that uses it.

Comment 7 David Deaderick 2003-04-02 14:30:08 UTC
I am seeing a similar occurence on Advanced Server 2.1 runing Oracle 9iAS.  The 
oafd process is remaining long after I log off of the oracle user ID, even with 
all Oracle processes shutdown.  The Gnome RPM is 1.4.0.4 in Red Had Enterprise 
Linux Advanced Server 2.1

UID        PID  PPID  C STIME TTY           TIME CMD
oracle    6267     1  0 09:20 ?         00:00:00 oafd --ac-activate --ior-
output-fd=17

Any ideas how to get this to go away?

Comment 8 Havoc Pennington 2003-10-09 04:12:24 UTC
Rendered irrelevant with the move to Evolution 1.4, there should not be any apps
starting up oafd anymore.