Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 84384

Summary: gnome-terminal loses keyboard focus (tabbed mode)
Product: [Retired] Red Hat Linux Reporter: Warren Togami <wtogami>
Component: vteAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: aoliva, mitr
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-05-11 19:59:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79578    

Description Warren Togami 2003-02-15 11:04:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
gnome-terminal when used in tabbed mode often will lose keyboard focus when
switching back & forth between other windows.  This is sometimes difficult to
reproduce but it happens quite often for me on several systems.  The normally
solid black cursor is stuck as the outline-only cursor and clicking the window
does not gain focus.

WORKAROUND: If you click on the "Go" menu and select "Previous Tab" or "Next
Tab" it regains the solid black cursor and keyboard focus.

Recent Rawhide versions of gnome-terminal began to exhibit this behavior.  I
think I didn't experience this problem with the initial gnome-terminal in
Phoebe2, but not entirely sure.

Version-Release number of selected component (if applicable):
gnome-terminal-2.2.1-2

Comment 1 Havoc Pennington 2003-02-15 14:26:41 UTC
I think the problem is just that clicking the terminal area doesn't focus it, so 
if you somehow get the focus elsewhere (e.g. clicking the active tab)
then you are in a fix.

Comment 2 Matt Wilson 2003-02-16 19:23:41 UTC
are you switching focus  between the windows using the keyboard (Alt+Tab or
similar)?

Comment 3 Warren Togami 2003-02-16 19:41:15 UTC
Yeah, Havoc was right.  Steps to reproduce:
1. Open gnome-terminal.
2. Hit CTRL-SHIFT-T a few times to open a few tabs.
3. Double-click on any tab.


Comment 4 Matt Wilson 2003-02-20 02:47:29 UTC
how is this a bug?  you're focusing the tab.  just hit tab to get back in the
next group (i.e., the terminal widget).


Comment 5 Matt Wilson 2003-02-20 02:48:46 UTC
IOW, Havoc, why are you allowing tabs to be focused?  And you want vte to grab
focus when someone clicks on it?


Comment 6 Matt Wilson 2003-02-20 02:51:44 UTC
this is fixed in GNOME CVS - clicking in the VTE widget grabs focus


Comment 7 Nalin Dahyabhai 2003-02-20 03:59:05 UTC
The tab can be focused for keynav purposes.  Either way, this should be fixed in
0.10.21 and later.