Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 84259

Summary: Enh: append to /boot/grub/grub.conf if it exists...
Product: [Retired] Red Hat Linux Reporter: Glen A. Foster <glen.foster>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED WONTFIX QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0Keywords: FutureFeature
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-13 21:32:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Glen A. Foster 2003-02-13 19:47:12 UTC
Description of problem: After installing RHAS2.1 to one slice of /dev/sda, I 
tried installing 8.0 to /dev/sdb for a dual-boot scenario.  Anaconda was nice 
enough to warn me about not being requested to format /boot, and I proceeded.
I told anaconda to install grub on /dev/sda (where it was after the RHAS2.1 
install), and everything was pretty OK.

Except, the stanza for RHAS2.1 was lost when /boot/grub/grub.conf was created. 
My enhancement request is to *append* boot stanza if /etc/grub/grub.conf 
already exists and you tell anaconda to not format /boot... maybe easier asked 
then done, but I'll submit the enhancement request anyway.

Comment 1 Jeremy Katz 2003-02-13 21:32:57 UTC
You can sort of do this if you a) mount your /boot and b) tell anaconda to not
touch your boot loader config.  Because then you'll get grubby updating your
boot loader config and get basically what you want.  Not something I'm really
looking at supporting (dual-boot is a definite outlier case)

Comment 2 Glen A. Foster 2003-02-13 22:12:39 UTC
I'd like to test your assertion/advice here by installing a more current RH 
distribution on top of what I have configured now... When you 
say "mount /boot", are you saying to switch to VC2 during an install and 
physically mount the device outside the realm of anaconda, or just 
specify /boot as a filesystem and do NOT format the partition?  I certainly 
understand the "don't touch the bootloader config" part.

And, if the former, at what point do I mount /boot, and on what specific 
directory (/boot, /mnt/sysimage/boot)?

Comment 3 Jeremy Katz 2003-02-13 22:22:50 UTC
Just specify the partition should be mounted as /boot and don't format the
partition.