Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 84249

Summary: sytems hangs during startup with demand dial ppp interface
Product: [Retired] Red Hat Linux Reporter: Martin Cheatle <martin.cheatle>
Component: pppAssignee: Thomas Woerner <twoerner>
Status: CLOSED NOTABUG QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: srevivo
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-08-16 16:16:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Martin Cheatle 2003-02-13 19:06:59 UTC
Description of problem:
sytems hangs during startup with demand dial ppp interface

Version-Release number of selected component (if applicable):


How reproducible:
Every Time

Steps to Reproduce:
1.enable on boot startup for interface
2.
3.
    
Actual results:
System attempts to start ppp interface and sits there whating to dial if it
fails it just waits.

Expected results:
if the system fails to dial the interface skip and retry in the background

Additional info:
looking into this problem i found that the line in
/etc/sysconfig/network-scripts/ifup-ppp
that reads 
[ "${TYPE}" = "xDSL" ] || exec /sbin/ppp-watch "${DEVICE}" "$@"
the system hangs because to many options are being passed to ppp-watch
placing a echo before that line taht reads
echo "${DEVICE}" "$@"
revealed that the following was being passed

ppp0 ifcfg-ppp0 boot

by changing the line to read
[ "${TYPE}" = "xDSL" ] || exec /sbin/ppp-watch "${DEVICE}" "$2"
and changeing the echo to reflect this 
echo "${DEVICE}" "$2"

ppp0 boot

are passed to ppp-watch and the system boots Ok every time.

Comment 1 Giacomo Magnini 2003-11-12 14:54:54 UTC
Dupe of bug 84169 ?

Comment 2 Martin Cheatle 2003-11-15 19:41:53 UTC
Yes sorry! 

Comment 3 Thomas Woerner 2004-08-16 16:16:26 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.