Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 84198

Summary: An "Unhandled Exception" pops up for no particular reason
Product: [Retired] Red Hat Linux Reporter: Polychronis Ypodimatopoulos <ypol>
Component: redhat-config-networkAssignee: Harald Hoyer <harald>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: michael
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:51:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Polychronis Ypodimatopoulos 2003-02-13 12:13:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Unfortunatelly I cannot reproduce this bug!
An Unhandled exception occurs with the following message:

Traceback (most recent call last):
  File "/usr/sbin/neat", line 774, in update_devicelist
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Control.py", line
63, in __init__
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Control.py", line
66, in load
OSError: Too many open files

I am building a small intranet with two subnets.
I think (but not 100% sure.... <:-( ) that this problem started occuring ever
since I installed a second network card on two computers. Still, the problem can
occur on ANY machine irrespective of the number of eth devices it has, or the
subnet it belongs to!

Help..............

PS The gateway machine for some reason has started behaving so very slow too.
Others work fine.

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce


Additional info:

Comment 1 Polychronis Ypodimatopoulos 2003-02-13 14:15:18 UTC
Some new info:
The exception occurs after having left the redhat-config-network open for some
time (around 45 minutes). The machine is idle whatsoever but the exception still
occurs.

Comment 2 Michael Lee Yohe 2003-02-13 14:25:35 UTC
This bug is a duplicate of Bug 74989.  You can obtain the update from Rawhide.

Comment 3 Harald Hoyer 2003-02-13 14:40:42 UTC

*** This bug has been marked as a duplicate of 74989 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:51:46 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.