Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 84195

Summary: root crontab does not work
Product: Red Hat Enterprise Linux 2.1 Reporter: Zoechmann Reinhard <reinhard.zoechmann>
Component: crontabsAssignee: Bill Nottingham <notting>
Status: CLOSED NOTABUG QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 2.1CC: rvokal
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-13 17:06:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Zoechmann Reinhard 2003-02-13 10:51:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0; QXW0340j)

Description of problem:
I want to use the root crontab.
I set up the system.
At this time root uses bash.
Then I changed the shell to ksh.

# crontab -e
no crontab for root - using an empty one
/bin/sh: emacs: command not found
crontab: "emacs" exited with status 127

On our system there is Oracle 9iAS Version 9.0.2 installed.
But the owner is an other user.

Crontab works with other users.
The hotline is not able to reproduce this problem at thair system.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.login as root
2.crontab -e
3.
    

Additional info:

Comment 1 Bill Nottingham 2003-02-13 17:06:36 UTC
Don't set EDITOR or VISUAL to emacs if it's not installed.