Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 84101

Summary: application bug: parallel(3961) has SIGCHLD set to SIG_IGN but calls wait4.
Product: [Retired] Red Hat Linux Reporter: Bill Nottingham <notting>
Component: cupsAssignee: Tim Waugh <twaugh>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-07-28 21:53:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79578    

Description Bill Nottingham 2003-02-12 04:50:26 UTC
SSIA.

Comment 1 Tim Waugh 2003-02-12 10:39:11 UTC
It's not in the parallel backend, but in the scheduler (scheduler/devices.c). 
The reason given in CHANGES.txt for this is:

        - The scheduler's LoadDevices() function was getting
          interrupted by the SIGCHLD signal handler; now ignore
          child signals while loading devices.

I don't want to re-introduce whatever bug that was.

Comment 2 Tim Waugh 2003-02-12 18:51:52 UTC
Fixed package is cups-1.1.17-13.

Comment 3 Bill Nottingham 2003-07-28 21:53:07 UTC
Closing some bugs that have been in MODIFIED for a while. Please reopen if the
problem persists.