Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 84042

Summary: XFree86 Glint gamma driver at 1600x1200
Product: [Retired] Red Hat Linux Reporter: Alan Cox <alan>
Component: XFree86Assignee: X/OpenGL Maintenance List <xgl-maint>
Status: CLOSED WONTFIX QA Contact: David Lawrence <dkl>
Severity: low Docs Contact:
Priority: low    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-11-28 12:45:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Alan Cox 2003-02-11 13:25:04 UTC
At 1600x1200x16bit the cursor stops working on the Oxygen GMX2000. Looks like
straight
memory bandwidth issues. Switching the cursor to software cures the problem.

Again mostly an FYI

Comment 1 Mike A. Harris 2003-02-11 14:11:35 UTC
Hmm.  It might be doable to have the driver force swcursor at 1600x1200,
but it would be a bit more complex than just determining at startup wether
or not to do so, as it would have to handle the vidmode extension, RandR,
and also CTRL-ALT +/- switching.  Probably not much effort though.

Might want to pass this to Alan H also.

Comment 2 Mike A. Harris 2004-09-24 20:36:56 UTC
Chatted with Kevin about this, and we think the best thing to do,
is to see if you can confirm if this still is a problem on Fedora
Core 2 or FC3test2 or not.  If it's still happening, it's probably
best to file a bug on X.Org bugzilla, and see if alanh or someone
else can take care of it.  Probably simple to fix, but easier if
someone who has the hardware can poke at it.

Could you have a look?

Comment 3 Alan Cox 2004-09-24 21:42:34 UTC
I reported it to AlanH at the time. From the conversations then I
don't think he cares about this obscure h/w anymore to be honest (nor
do I blame him). 

The fix I ended up with is 

  if(x * y * bytedepth > 3120000) -> swcursor

unfortunately I don't have docs to verify or "officially" fix this.


Comment 4 Alan Cox 2004-09-24 21:42:54 UTC
(Will retest on FC3test2)

Comment 5 Mike A. Harris 2004-11-28 12:45:09 UTC
Ok, if you've got a unified diff of a confirmed fix for this,
please submit it to X.Org bugzilla.  I'm going to close this
one "WONTFIX" for now.