Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 84026

Summary: gdm does not update /var/run/utmp correctly
Product: [Retired] Red Hat Linux Reporter: Norman Gaywood <ngaywood>
Component: gdmAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED DUPLICATE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: jirka
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-11-10 20:44:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579, 100644    

Description Norman Gaywood 2003-02-11 02:59:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
gdm does not update /var/run/utmp correctly when logging in via xdmcp. The first
user seems to be added correctly but all subsequent logins replace the previous
login. So 'who/w/finger' only ever shows one X terminal style login even though
there are many more.

wtmp seems to be correct. That is, last correctly shows that last and current
logins.

The only changes I have made to the gdm setup from a default install is to the
gdm.conf file. Here is the diff between my gdm.conf and the one supplied in RH 8.0

diff gdm.conf gdm.conf-redhat
72c72
< Enable=true
---
> Enable=false
74,78c74,78
< MaxPending=10
< MaxPendingIndirect=10
< MaxSessions=80
< MaxWait=30
< MaxWaitIndirect=30
---
> MaxPending=4
> MaxPendingIndirect=4
> MaxSessions=16
> MaxWait=15
> MaxWaitIndirect=15
149c149
< #0=Standard
---
> 0=Standard


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Make changes to gdm.conf to allow xdmcp logins
2. restart gdm
3. start logins from 2 or more xterminals via xdmcp and observe the output of
who/w/finger
    

Actual Results:  Only the last xdmcp login is displayed with who/w/finger even
though the last command shows more than one "still logged in".

Expected Results:  All users should be in who/w/finger output

Additional info:

Comment 1 George Lebl 2003-07-23 19:20:14 UTC
Note that this is the way that the redhat package handles the Pre/PostSession
scripts.  upstream will handle this correctly.

Comment 2 George Lebl 2003-08-04 19:01:03 UTC
Hmmm, apparently recent RPMS do this correctly, but I think if you upgrade from
a version that did it wrongly (don't know which was the last version that did
that) you might still get wrong links in the PreSession/PostSession dirs.  See
bug #101105 since that's related (well really the same exact problem I think).

Comment 3 Ray Strode [halfline] 2004-11-10 20:44:48 UTC

*** This bug has been marked as a duplicate of 101105 ***