Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83984

Summary: Quotas fail for some users on a 3000+ users raid0 volume
Product: [Retired] Red Hat Linux Reporter: Christian Tosta <tosta>
Component: quotaAssignee: Steve Dickson <steved>
Status: CLOSED CURRENTRELEASE QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: sam
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-01-12 12:28:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Christian Tosta 2003-02-10 18:35:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
I'm implementating quotas for users in a Samba 2.2.7 PDC for Rwindows XP clients. When I run (for example) 'setquota -u 9911054 20000 20000 0 0 /home' the command don't return errors. But when I do a 'quota username' then return "Disk quotas for user #9911054 (uid 9911054): none".

My /home is mounted from /dev/md1 which is a raid0 device spanned into two discs and formatted with ext2 filesystem.

I think is problem the name of the user (a numeric code)??

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create a numeric username for a new user
2.Set the quota for this user in volume /home (raid0)
3.Check the quota for this user
    

Actual Results:  Quota is "none" when I check quota for user

Expected Results:  Quota must to be the value I set to user

Additional info:

Comment 1 Christian Tosta 2003-02-12 19:54:17 UTC
Problem occur when you try to setup disc quotas for users with a numeric 
username (not specially on raid devices). You need alfa-numeric usernames to 
quota works, otherwise it choose random users to set the quota.

Comment 2 Need Real Name 2003-05-12 22:15:01 UTC
Weellll - None of my usernames are entirely numeric

I'm using redhat 8 with quotas on a new 120G ext3 file system and as I "rsync
-a" files over I notice some usernames aren't showing up in repquota

Once I get a couple of thousand users transferred repquota starts segfaulting

[It's not really a backup, don't worry about the mountpoint name]

[root@backup users]# ls -l /backup/aquota.*
-rw-------    1 root     root         8192 May 12 23:22 /backup/aquota.group
-rw-------    1 root     root       149504 May 12 23:22 /backup/aquota.user

[root@backup users]# repquota /backup
*** Report for user quotas on device /dev/hdc1
Block grace time: 7days; Inode grace time: 7days
                        Block limits                File limits
User            used    soft    hard  grace    used  soft  hard  grace
----------------------------------------------------------------------
Segmentation fault

Is the the same fault? It gets worse as the number of users goes up

Comment 3 Need Real Name 2003-05-13 20:29:46 UTC
Actually the segfault stops when I used the -n flag to repquota

But still not all user-id's show up.


Comment 4 Mark J. Cox 2004-01-05 09:38:53 UTC
have you tried this with a later distribution (RHEL 3 or RHL 9)?

Comment 5 Need Real Name 2004-01-05 10:34:35 UTC
I've not, its not a box we can update easily.

We since had such bad problems of users reportedly using a large 
quantity of disk space when a "find" for that user reports otherwise 
that we had to rebuild quotas entirely.