Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 8394

Summary: sndconfig selects wrong driver for sound blaster pci 128
Product: [Retired] Red Hat Linux Reporter: Nick Boehling <dirtynick>
Component: sndconfigAssignee: Bill Nottingham <notting>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-01-21 06:24:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Nick Boehling 2000-01-12 06:18:39 UTC
I have a SoundBlaster PCI 128 sound card installed and sndconfig detects it
as a Ensoniq ES 1371 Audio PCI-97.  When testing it freezes the system up.
My motherboard is a Asus BM6 and I have tried selecting the option for PNP
OS as yes and no in the bios.

Comment 1 Bill Nottingham 2000-01-13 15:34:59 UTC
Does it hang the system completely, or just hang
sndconfig?

The card designation is correct; all of the Soundblaster PCI<x>
cards (except for the 512) are based off of the es1370 or es1371
chips.

Comment 2 Nick Boehling 2000-01-18 06:49:59 UTC
sndconfig is the only part that stops after I say OK to test the sound card.  I
can type  but the only way to exit is ctrl-c.  It displays this information:

es1371: unloading
es1371: version v.013 time 10:31:53 Sep 27 1999
es1371: found adapter at io 0xe800 irq 15
es1371: features joystick 0x0
es1371: codec vendor revision 0
es1371: codec features none
es1371: stereo enhancement: no         3D stereo enhancement

Then nothing else, no sound or anything so have to press ctrl-c to exit the
program.program.

Now when I boot klogd uses all of the cpu usage and has to be killed.

Comment 3 Bill Nottingham 2000-01-18 16:30:59 UTC
OK, looks like you have one of the newer chips. It's
currently supported in the 2.2.15pre2 or greater kernel;
you can get the patch from

ftp://ftp.us.kernel.org/pub/linux/kernel/people/alan/

Comment 4 Bill Nottingham 2000-01-21 06:24:59 UTC
*** This bug has been marked as a duplicate of 5806 ***