Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83826

Summary: Burning a CD using RH8.0 at runlevel 5 causes failed burn (coaster) and lots of scsi errors.
Product: [Retired] Red Hat Linux Reporter: Leigh Orf <leigh.orf>
Component: magicdevAssignee: Owen Taylor <otaylor>
Status: CLOSED DUPLICATE QA Contact: David Lawrence <dkl>
Severity: high Docs Contact:
Priority: high    
Version: 8.0CC: jch, mitr
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:51:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Leigh Orf 2003-02-09 17:39:19 UTC
Description of problem: Burning a CD with RedHat 8.0 consistenly
fails with scsi errors due to concurrent access to /dev/scd0 by
magicdev process


Version-Release number of selected component (if applicable):


How reproducible: Log in under runlevel 5 (X). A process called
magicdev will be spawned.


Steps to Reproduce:
1. Log in at runlevel 5 (X)
1. sudo cdrecord -audio -dao dev=0,0,0 speed=4 *.wav
2. cdrecord will begin burning and will crash. many scsi errors in /var/log/messages

Actual results:


Expected results:


Additional info: If you kill magicdev this problem goes away! Magicdev
is concurrently accessing /dev/scd0 which messes up the cd burn.

As far as I can tell anyone who tries to burn a CD using RH 8.0
with the ide-scsi module should have this problem.

I am using the default 8.0 configuration except I am using the sawfish
window manager.

Comment 1 David Lawrence 2003-02-09 23:12:29 UTC
*** Bug 83825 has been marked as a duplicate of this bug. ***

Comment 2 John Haxby 2003-02-11 10:36:45 UTC
Autorun has an option to watch only named devices -- under RH7.2 I used to have
it ignore my CD writer.   Now with Magicdev under 8.0 I can't find out how to
ignore the cd-writer so I just make sure I kill magicdev if I don't want to make
coffee mats.

Ideally, of course, magicdev would "know" when a CD writer is being used for
writing and not watch it until it's been finished with, but I'd settle for an
option to ignore some devices ...

Comment 3 Owen Taylor 2003-02-11 19:20:05 UTC
You can turn off magicdev entirely from Preferences/CD and DVD.

We have some plans in the future for locking access to the CD device,
for now, on problematical hardware you'll just have to turn magicdev
off.


*** This bug has been marked as a duplicate of 34433 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:51:40 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.