Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83824

Summary: German package description is only displayed to the first special character
Product: [Retired] Red Hat Linux Reporter: Jens Kager <jenskager>
Component: up2dateAssignee: Adrian Likins <alikins>
Status: CLOSED RAWHIDE QA Contact: Fanny Augustin <fmoquete>
Severity: low Docs Contact:
Priority: medium    
Version: 8.0CC: gafton, mihai.ibanescu, mitr
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-14 04:17:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Screenshot of Update Agent while displaying a truncated description none

Description Jens Kager 2003-02-09 15:58:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

Description of problem:
The German package descriptions are not displayed properly: The text is cut off
from the occurence of the first umlaut on (�, �, �; maybe other special
characters will also produce this, but I couldn't observe that until now). To be
precise, the umlaut itself is also not displayed any more, but most of the time
it is obvious that one should follow because you can guess the word from the
context.

For example, for the kernel-source package I'd only see the description "Der
Quellcode f", when there should probably follow a description like "Der
Quellcode f�r den Linux-Kernel..." or something similar.

The text is never cut off at arbitrary points, it's every time at the points
where such umlauts occur, and if none occur (which, however, is very rare), it
is displayed perfectly to the end.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use German localization.
2. Start Update Agent.
3. Download packages.
4. Marvel at the mutilated descriptions.

Additional info:

Comment 1 Jens Kager 2003-02-09 16:03:11 UTC
Hm, I see that there are some problems with German special characters here as
well. I hope the message I wanted to convey is clear nevertheless (the umlauts I
am talking about are ae, oe and ue, here in their transcription as plain
characters).

Comment 2 Jens Kager 2003-02-09 16:04:09 UTC
Created attachment 89954 [details]
Screenshot of Update Agent while displaying a truncated description

Comment 3 Adrian Likins 2003-02-10 20:46:02 UTC
hmm, any idea when this bug started? or has it
always been broken?

Comment 4 Adrian Likins 2003-02-10 21:27:21 UTC
looks like I wasnt setting the charset properly,
should be fixed with 3.1.16 or higher 



Comment 5 Jay Turner 2003-02-14 04:17:19 UTC
Fix confirmed with up2date-3.1.15-7.