Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83817

Summary: ide-scsi problem with CD-read
Product: [Retired] Red Hat Linux Reporter: Need Real Name <mal>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-06-05 14:53:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Need Real Name 2003-02-09 11:31:12 UTC
I get messages in /var/log/messages
about "attempt to access beyond end of device".
This happend both with kernel-2.4.18-24.8.0
and 2.4.18-19.8.0. 
grub.conf has hdc=ide-scsi

	kernel /vmlinuz-2.4.18-24.8.0 ro root=LABEL=/ hdc=ide-scsi

The RDRW mode is: "LG CD-RW CED-8080B"
Loaded modules are:

 /sbin/lsmod 
Module                  Size  Used by    Not tainted
sg                     36588   0  (autoclean)
loop                   12152   0  (autoclean)
smbfs                  43680   2  (autoclean)
sr_mod                 18168   0  (autoclean)
es1371                 30760   0  (autoclean)
ac97_codec             13416   0  (autoclean) [es1371]
gameport                3412   0  (autoclean) [es1371]
soundcore               6532   4  (autoclean) [es1371]
i810                   72736   1 
agpgart                43136   7  (autoclean)
autofs                 13348   0  (autoclean) (unused)
eepro100               22264   1 
ipt_REJECT              3736   2  (autoclean)
iptable_filter          2412   1  (autoclean)
ip_tables              15224   2  [ipt_REJECT iptable_filter]
ide-scsi               10512   0 
scsi_mod              107240   3  [sg sr_mod ide-scsi]
ide-cd                 33608   0 
cdrom                  33696   0  [sr_mod ide-cd]
mousedev                5524   1 
keybdev                 2976   0  (unused)
hid                    22244   0  (unused)
input                   5920   0  [mousedev keybdev hid]
usb-uhci               26188   0  (unused)
usbcore                77024   1  [hid usb-uhci]
ext3                   70336   3 
jbd                    52212   3  [ext3]

--------------------- Error messages -----------

Feb  2 05:35:36 host133 kernel: attempt to access beyond end of device
Feb  2 05:35:36 host133 kernel: 0b:00: rw=0, want=34, limit=2
Feb  2 05:35:36 host133 kernel: isofs_read_super: bread failed, dev=0b:00,
iso_blknum=16, block=16
Feb  2 05:35:46 host133 kernel: attempt to access beyond end of device
Feb  2 05:35:46 host133 kernel: 0b:00: rw=0, want=34, limit=2
Feb  2 05:35:46 host133 kernel: isofs_read_super: bread failed, dev=0b:00,
iso_blknum=16, block=16
Feb  2 05:36:14 host133 kernel: attempt to access beyond end of device
Feb  2 05:36:14 host133 kernel: 0b:00: rw=0, want=34, limit=2
Feb  2 05:36:14 host133 kernel: isofs_read_super: bread failed, dev=0b:00,
iso_blknum=16, block=16


Feb  9 03:30:16 host133 kernel: attempt to access beyond end of device
Feb  9 03:30:16 host133 kernel: 0b:00: rw=0, want=34, limit=2
Feb  9 03:30:16 host133 kernel: isofs_read_super: bread failed, dev=0b:00,
iso_blknum=16, block=16
Feb  9 03:30:37 host133 kernel: attempt to access beyond end of device
Feb  9 03:30:37 host133 kernel: 0b:00: rw=0, want=34, limit=2
Feb  9 03:30:37 host133 kernel: isofs_read_super: bread failed, dev=0b:00,
iso_blknum=16, block=16

Comment 1 Dmitri A. Sergatskov 2003-02-26 20:20:20 UTC
I guess this is a "Me too" comment. The problem is pretty much the same, though
the hardware is quite different:

Tyan Tiger MP S2460 2xAMD MP 2400+
CD/RW is on Maxtor (promise OEM 133TX2) 133 controller (hdg)
I have to boot with 'noapic' or computer locks-up sporadically.



Comment 2 Dmitri A. Sergatskov 2003-02-27 18:54:04 UTC
Upgrading to the rawhide kernel (2.4.20-2.54smp) seems to solve both problems:
I can read CDs again and it has not locked up (there is no 'noapic' this time)
yet (~20 hours).

Sincerely,

Dmitri.