Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83772

Summary: orinoco_pci driver locks up
Product: [Retired] Red Hat Linux Reporter: Peter Bowen <pzbowen+rhbeta>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:51:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Peter Bowen 2003-02-08 04:59:45 UTC
network card dies and dmesg is full of line after line of:

eth1: Error -110 writing Tx descriptor to BAP

lspci -vv
01:02.0 Network controller: Harris Semiconductor Prism 2.5 Wavelan chipset (rev 01)
        Subsystem: Intel Corp. Wireless 802.11b MiniPCI Adapter
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV+ VGASnoop- ParErr-
Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at f8000000 (32-bit, prefetchable) [size=4K]
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0+,D1+,D2+,D3hot+,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

Comment 1 Peter Bowen 2003-02-11 03:25:58 UTC
This occurs with regularity with recent kernels including

kernel-2.4.20-2.36
kernel-2.4.20-2.39
kernel-2.4.20-2.41

all for i686.  This bug makes working very painful as I have to run the
following command regularly:

ifdown eth1; rmmod orinoco_pci orinoco hermes; ifup eth1

Comment 2 Peter Bowen 2003-02-19 03:03:07 UTC
OK, I found a fix for this.  Upgrading to 0.13b drivers from
http://ozlabs.org/people/dgibson/dldwd/ fixes it.  I haven't seen any lockups
since then, and the README suggests that 0.13 fixes at least on known reason for
the lockup.

Comment 3 Chris Runge 2003-02-20 22:30:58 UTC
I'm also seeing this problem on my IBM Thinkpad T30 which has the same wireless
chipset and uses the same driver.

The problem occurs under Red Hat Linux 8.0 as well as Phoebe 8.0.94
(kernel-2.4.20-2.48)

Comment 4 Dave Jones 2003-10-29 17:45:36 UTC

*** This bug has been marked as a duplicate of 80942 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:51:38 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.