Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83765

Summary: Disk Druid Crashed During Partition Edit
Product: [Retired] Red Hat Linux Reporter: ccain
Component: anacondaAssignee: Michael Fulbright <msf>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-05-25 14:52:05 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Anaconda Stack Trace none

Description ccain 2003-02-08 00:04:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
While setting up my partitions during a RH install, Disk Druid hit a fatal error
and bombed out. I had actually already allocated all of the disk space and was
in the process of editing the size of one. Specifically, I was bumping up the
size on one of my ext3 partitions, hoping it would steal the extra space from
swap (which was set to use "all remaing space"). Not sure if that's relevant to
the crash or not, but that's what I was doing at the time.

Anyway, I've attached the trace it generated.

(Sorry if this is a dupe ... although a few existing bugs looked plausible, none
seemed definitively the same, so I'm submitting just in case.)


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Use disk drooler to allocate all space into partitions.
2. Leave one set to "use remaining space" (not completely sure it's necessary,
but it's what I did).
3. Edit one of the other (specifically-sized) partitions and allocate more space
to it.
4. Hit "OK"
    

Actual Results:  Anaconda threw a stack trace window.

Expected Results:  Was expecting that it would either steal the extra space from
the "dynamically allocated" partition, or maybe just tell me there was not
enough free space to complete the change.

Additional info:

The drive itself is quite small (2G) and IDE (/dev/hda). It had a previous Win
installation on it, so I had deleted the existing FAT32 partition (in Disk
Druid) before setting up the new partitions.

Comment 1 ccain 2003-02-08 00:06:03 UTC
Created attachment 89939 [details]
Anaconda Stack Trace

Comment 2 Jeremy Katz 2003-02-10 19:34:07 UTC
Added code to keep this from happening in the future.

Comment 3 Brent Fox 2003-05-25 14:52:05 UTC
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.