Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 8370

Summary: nfs doesn't work
Product: [Retired] Red Hat Linux Reporter: alan
Component: nfs-serverAssignee: Cristian Gafton <gafton>
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1CC: andrewb
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-07 22:44:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description alan 2000-01-11 11:33:36 UTC
Following the written documentation for using NFS in RH 6-1 doesn't work.
Any attempt to mount an exported file system returns the error message

mount: RPC: Program not registered

Other programs, such as showmount -e, return similar messages.

Cannot do anything with /etc/rc.d/init.d/nfs because there is no file
named nfs in that directory. Is there some package I need to install to
use nfs? This happens on machines where I've installed Linux as a Gnome
Workstation as well as a KDE workstation.

Comment 1 Jeff Johnson 2000-02-07 22:44:59 UTC
The file /etc/rc.d/init.d/nfs is in the knfsd package. Make sure that you
have that (and the knfsd-clients) package(s) installed. You will also have
to make sure that the daemons are started in the correct order (a reboot will
insure that).