Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 837

Summary: ypbind cannot bind to domain on NIS server
Product: [Retired] Red Hat Linux Reporter: landrye
Component: ypbindAssignee: David Lawrence <dkl>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-01-15 16:06:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description landrye 1999-01-15 05:47:05 UTC
The default start and stop orders for the NIS daemons are
wrong.

cd /etc/rc.d/init.d
grep chkconfig yp*

ypbind:# chkconfig: - 13 87
yppasswdd:# chkconfig: - 66 34
ypserv:# chkconfig: - 65 35

ypbind is started before and stopped after ypserv but ypbind
depends on ypserv.

This makes it difficult to run NIS clients on the same
machine as an NIS server (to for example use netgroups).

What is the best solution to this problem?  I had thought of
changing the initscripts to change the start and stop order
but I think this might have hidden dependencies with other
packages.

Comment 1 landrye 1999-01-15 05:58:59 UTC
See also bug 264

URL: http://developer.redhat.com/bugzilla/show_bug.cgi?id=264

Comment 2 Jeff Johnson 1999-01-15 16:06:59 UTC
*** This bug has been marked as a duplicate of 264 ***