Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83694

Summary: redhat-config-printer quite useless in a text mode
Product: [Retired] Red Hat Linux Reporter: Michal Jaegermann <michal>
Component: newtAssignee: Eido Inoue <havill>
Status: CLOSED WORKSFORME QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: srevivo, twaugh
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-09-10 18:14:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michal Jaegermann 2003-02-07 04:26:14 UTC
Description of problem:

An attempt to configure a printer in text mode on console does not
show anything which can be actually used.  What is on a screen is not
really readable, with a cursor position which can be only guessed and
selected buttons "jumping" around once "pressed".  It is possible to
type in a queue name and pick up a type but that seems to be about it.
At that point apparently the only possible actions (hard really tell
but few blind tries did not reveal anything else) is either "Next" or
"Cancel" and none of that results in anything resembling a printer
configuration.

Readability is not a strong point of any of "tui" configuration
utilities but 'redhat-config-printer' seems here to be taking the
cake.


redhat-config-printer-0.6.35-1

Comment 1 Tim Waugh 2003-02-07 09:04:13 UTC
If you don't have newt-0.51.4-1 installed yet, please fetch it from rawhide.

If that doesn't correct the problem, please let me know what 'echo $LANG' says.

Comment 2 Michal Jaegermann 2003-02-09 01:16:13 UTC
Indeed, with 'newt' from rawhide I can get some reaction and it
is possible to configure something.  OTOH readability is still not
that great and after selecting a button I see things like

      Exit
        Exit

on my screen.  Not a show-stopper but somewhat annoying.


Comment 3 Tim Waugh 2003-02-09 15:51:31 UTC
I don't see this.  I see a perfectly normal display, with no glitches.  Please
tell me what you have for $LANG, and which VT you are using (1, or something else).

Comment 4 Michal Jaegermann 2003-02-09 17:37:01 UTC
I tried with few different settings of LANG ranging between C and en_CA
with en_CA.utf8.  I did not see much of a difference.  OTOH my current
beta installation is partial due to a physical damage on one of received
CDs.  I will return to the issue later when I will have something more
akin to a "standard" setup.  OTOH if these displays are so "sensitive"
that this likely means that one will get into a trouble trying to use
configuration tools over a network without X.

"Doubling", like mentioned above, happens only on selected buttons and
follows you reverting to the original display when some other button is
selected.

I was running tests mostly on vt1 but I do not see anything different on vt2.


Comment 5 Eido Inoue 2003-09-10 18:14:36 UTC
I can't reproduce this either. Sometimes when I switch between graphics mode and
text consoles, I need to redo the "unicode_start" command to get the correct
line drawing characters, but once I do this, I can't see any of the problems
described in this report.