Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83618

Summary: (Konqueror) Hard coded Mozilla plugin directory
Product: [Retired] Red Hat Public Beta Reporter: Warren Togami <wtogami>
Component: kdebaseAssignee: Ngo Than <than>
Status: CLOSED RAWHIDE QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: phoebe   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-06 15:36:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Warren Togami 2003-02-06 11:53:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030203

Description of problem:
kdebase .src.rpm SOURCES/kcmnspluginrc:
[Misc]
scanPaths=/usr/lib/mozilla-1.0.1/plugins,/usr/lib/mozilla/plugins,/usr/lib/netscape/plugins,$HOME/.netscape/plugins,/usr/local/netscape/plugins,/opt/netscape/plugins,/opt/netscape/communicator/plugins,/usr/lib/netscape/plugins-libc5,/usr/lib/netscape/plugins-libc6,$MOZILLA_HOME/plugins
startkdeScan=false
useArtsdsp=true

The hard coded Mozilla path hasn't been updated since Psyche.  This could be
fixed easily with another change, however is there any cleaner and more
permanent solution?

(I already tried using wildcards, doesn't work in Konqueror's nspluginscan.)

Version-Release number of selected component (if applicable):
kdebase-3.1-4.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. Use Konqueror

Actual Results:  
Mozilla plugins don't work because they are not in the default plugin scan
directories.

Expected Results:  
Mozilla's plugin directory should be within the default plugin scan directories.

Comment 1 Ngo Than 2003-02-06 15:36:34 UTC
mozilla should have a symlink to /usr/lib/mozilla/plugins. It could be a clean
solution.

anyway, it's fixed in 3.1-5