Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 8359

Summary: PPP problem with IP Masq
Product: [Retired] Red Hat Linux Reporter: Phillip Turner <techmav>
Component: pppAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-01-19 23:46:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Phillip Turner 2000-01-11 01:30:37 UTC
Upgraded to RH6.1 and started having problems with the PPP.
I am running IP Masq on the system. When I try to connect to my
ISP, the PPP Daemon insists on using PAP to auth the connection.
The ISP is a script-based connection, running RH 5.2.
Had to uninstall ppp-2.3.10-1 and install ppp-2.3.7-2 to get connected.
If I disable the NIC in the system, it connects under ppp-2.3.10-1 fine.
enable the NIC and it goes back to trying to use PAP.

Comment 1 Nalin Dahyabhai 2000-01-17 16:34:59 UTC
Please upgrade to the latest versions of the initscripts and ppp packages
available from our web server, and see if they fix your problem:
http://www.redhat.com/support/errata/RHSA1999052-04.html
http://www.redhat.com/support/errata/RHEA1999051-01.html

Comment 2 Phillip Turner 2000-01-18 00:17:59 UTC
Upgraded to the latest versions of initscript and ppp. Still having same
problem. Had to go back to ppp-2.3.7-2 to get back online.  Phillip Turner

Comment 3 Nalin Dahyabhai 2000-01-19 14:57:59 UTC
I don't think IP masq has anything to do with it, but I think I've seen odd
behavior when the dialing machine already had a default route set before
starting PPP.  Do you have a GATEWAY or GATEWAYDEV defined in
/etc/sysconfig/network?  If you do, try removing them.

Comment 4 Phillip Turner 2000-01-19 23:06:59 UTC
That was the problem. I removed the Gateway and GatewayDev, restarted the
network, and everything seems to be fine now. Thank you for your time and help
on this.

Phillip Turner