Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83581

Summary: Glib 2.2 can't work with older libgnomeui
Product: [Retired] Red Hat Linux Reporter: Göran Uddeborg <goeran>
Component: glib2Assignee: Matthias Clasen <mclasen>
Severity: low Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-05-19 20:40:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Göran Uddeborg 2003-02-05 19:40:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
After upgrading some packages, among them glib2, almost all Gnome-related
programs started to crash.  Owen Taylor explained the background for this:

   You need to upgrade your libgnomeui package. The somewhat detailed  
   explanation is that

   - It's been illegal to create base class types like GObject, or tkWidget. But 
     it used to more or less do something.

   - We enforced the restriction in GLib-2.2, which showed that libgnomeui was 
     doing g_object_new (GTK_TYPE_WIDGET, NULL); in one spot, which caused a 

There oght to be attributes in the RPM:s to protect this from happening. 
(Assuming no --force or similar, of course.)

Version-Release number of selected component (if applicable):

How reproducible:

Additional info:

A "Conflicts: libgnomeui < 2.1.90" in glib2 looks like an appropriate thing to me.

Comment 1 Matthias Clasen 2004-05-19 20:40:23 UTC
There's acutally a Conflicts: libgnomeui <= 2.2.0