Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83572

Summary: mysql.sock, Can't connect to local MySQL server through socket
Product: [Retired] Red Hat Linux Reporter: Anders Aleborg <anders>
Component: mysqlAssignee: Patrick Macdonald <patrickm>
Status: CLOSED WORKSFORME QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: high    
Version: 7.3   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-05 20:20:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Anders Aleborg 2003-02-05 18:34:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
after upgrading to all the latest patches for RH7.3 mysql.sock can't be found 
at the system.

ERROR 2002: Can't connect to local MySQL server through 
socket '/var/lib/mysql/mysql.sock' (2)

have searched for it but it can't be found anywhere so now MySQL can't be 
started!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. mysql -u root
2. mysql start
3.
    

Actual Results:  I get:
ERROR 2002: Can't connect to local MySQL server through 
socket '/var/lib/mysql/mysql.sock' (2)


Expected Results:  1. Ishould be able to login to mysql
2. MySQL should start

Additional info:

Comment 1 Patrick Macdonald 2003-02-05 19:34:18 UTC
It looks as though your mysql server is not running. Restart mysqld
using "service mysql restart" and you should be able to connect.  Let
me know if this does not solve your problem.

Comment 2 Anders Aleborg 2003-02-05 20:20:26 UTC
Ahh, now it works using "service mysqld restart" !

Thanks!