Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 8352

Summary: date -f : Segmentation fault
Product: [Retired] Red Hat Linux Reporter: Lew Riley <rileyle>
Component: sh-utilsAssignee: bero
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-03 21:42:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Lew Riley 2000-01-10 23:23:56 UTC
Using the -f switch with the date command, the date strings in the file are
processed properly, and then I get a segmentation fault. For example:

$ date > t.t
$ date >> t.t
$ date -f t.t
Mon Jan 10 18:29:25 EST 2000
Mon Jan 10 18:29:29 EST 2000
Segmentation fault (core dumped)
$

This was not a problem on RedHat 5.2. Running strace, it looks like a final
read runs off the end of the file causing the fault.

Comment 1 Elliot Lee 2000-02-03 21:42:59 UTC
Works with the 'date' on my system, I'll assume it has been fixed recently.