Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83457

Summary: Prefix /etc/http/conf.d/*.conf files with numbers like in /etc/rc3.d
Product: [Retired] Red Hat Linux Reporter: Soren Roug <soren.roug>
Component: httpdAssignee: Joe Orton <jorton>
Status: CLOSED WONTFIX QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: mitr
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-03-31 15:00:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Soren Roug 2003-02-04 16:55:29 UTC
Feature request: In case there are dependencies between the modules loaded 
from /etc/httpd/conf.d, I will recommend you put two-digit number prefixes on 
all .conf files to ensure they are loaded in the correct order.

Comment 1 Joe Orton 2003-02-04 16:59:07 UTC
We considered this, but there aren't supposed to be load-order dependencies
between modules in 2.0 due to the new hooks API.   A few have cropped up since
that decision was taken, of course.

Comment 2 Joe Orton 2003-03-31 15:00:24 UTC
I'll mark this as WONTFIX until we find a case where this is actually needed.