Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83376

Summary: more(1) doesn't handle UTF-8
Product: [Retired] Red Hat Raw Hide Reporter: Tim Waugh <twaugh>
Component: util-linuxAssignee: Tim Waugh <twaugh>
Status: CLOSED RAWHIDE QA Contact: Ben Levenson <benl>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-02-03 18:11:49 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
util-linux-2.11y-multibyte.patch none

Description Tim Waugh 2003-02-03 16:12:00 UTC
Description of problem:
more(1) doesn't handle UTF-8 correctly.  In particular, underlining is broken.

Version-Release number of selected component (if applicable):
util-linux-2.11y-2

How reproducible:
100%

Steps to Reproduce:
1. Start gnome-terminal.
2. echo -ne '\137\010\342\200\220\012' | more

Actual results:
??? (first '?' underlined)

Expected results:
- (underlined)

It's because it wraps the 'underline on', 'underline off' code around the first
byte of the multibyte character, rather than the whole thing.

Comment 1 Tim Waugh 2003-02-03 17:08:27 UTC
Created attachment 89804 [details]
util-linux-2.11y-multibyte.patch

This patch fixes it for me.

Comment 2 Tim Waugh 2003-02-03 18:11:14 UTC
Fixed package is util-linux-2.11y-5.