Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83365

Summary: <kadm5/admin.h> header-file missing
Product: [Retired] Red Hat Raw Hide Reporter: Enrico Scholz <rh-bugzilla>
Component: krb5Assignee: Nalin Dahyabhai <nalin>
Status: CLOSED WONTFIX QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: chris.ricker, julio.sanchez, mitr, notting
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-08-08 13:29:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 79579, 100644, 144057    

Description Enrico Scholz 2003-02-03 13:10:02 UTC
Description of problem:

The kadm5 headers are missing:

| $ cat foo.c
| #include <kadm5/admin.h>
| $ gcc `/usr/kerberos/bin/krb5-config --cflags  kadm-client` foo.c
| foo.c:1:25: kadm5/admin.h: No such file or directory

Including <kadm5/admin.h> is the way described by
/usr/share/doc/krb5-devel-1.2.7/kadm5/api-funcspec.tex


Version-Release number of selected component (if applicable):

krb5-devel-1.2.7-5

Comment 1 Julio Sanchez Fernandez 2003-03-13 17:50:09 UTC
This problem makes impossible compiling pam_krb5_migrate 0.0.4 that, BTW, would
be nice to have it included by RedHat.

I have verified that it these headers are missing on 7.3 (released an errata),
8.0, Phoebe and current Rawhide (that seems to be krb5-devel-1.2.7-7)


Comment 2 Julio Sanchez Fernandez 2003-05-27 09:55:34 UTC
I have rechecked and they are still missing from both RedHat Linux 9 and the
current rawhide, even though the package has been updated on rawhide on May 22nd.

Would filing a new bug against RedHat Linux 9 improve the chances of this being
fixed?

Comment 3 Gerasimos Melissaratos 2003-07-31 07:22:54 UTC
This bug is due to the usage of MIT Kerberos V instead of Heimdal Kerberos V in  
RedHat. Download from ftp://ftp.pdc.kth.se/pub/heimdal/src/heimdal-0.6.tar.gz, 
extract, run configure with a prefix like  
"./configure --prefix=/usr/local/heimdal" 
then "make install". 
Next step is to fix the pam_krb5_migrate Makefile and "pam_krb5_migrate.h" header 
file. Change in the Makefile the line  
"CFLAGS += -I/usr/kerberos/include" 
to  
"CFLAGS += -I/usr/local/heimdal/include" 
 
Then edit the header file and add under the last #include statement the line 
#include <kadm5/kadm5_err.h> 
 
Run "make all install" for the pam module and everything should run smoothly. You 
can remove the directory /usr/local/heimdal after that. It's not the best of fixes, but it 
works. 

Comment 4 Julio Sanchez Fernandez 2003-08-01 08:01:57 UTC
I don't think it is a Heimdal vs. MIT problem, older versions of the MIT RPMS
included that file.

Comment 5 Chris Ricker 2003-11-07 03:50:14 UTC
It's definitely not Heimdal vs MIT. The stock MIT krb5 1.3.1 source
tree includes src/lib/kadm5/admin.h ; not sure why it's not included....


Comment 6 Enrico Scholz 2004-01-14 16:13:37 UTC
still with krb5-devel-1.3.1-7


Comment 7 Enrico Scholz 2004-01-14 19:12:56 UTC
When you want a quick hack, please consider to do QA on

https://bugzilla.fedora.us/show_bug.cgi?id=1219

Comment 8 Miloslav Trma─Ź 2005-01-10 22:19:18 UTC
This also makes it impossible to resurrect the krb5
support in libuser.

Comment 9 Bill Nottingham 2006-08-08 01:53:27 UTC
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.


Comment 10 Nalin Dahyabhai 2006-08-08 13:29:51 UTC
The kadmin library is internal to MIT Kerberos and isn't part of the ABI which
upstream attempts to maintain.  Including it in the original RHL packages was a
mistake on my part.  Marking won't-fix.

Comment 11 Aleksandar Milivojevic 2006-11-28 19:59:12 UTC
Internal to MIT Kerberos or not, there's so much stuff out there that uses
kadmin library that it would be useful to have it back.  For example the only
PHP kerberos extension (kadm5) I know of needs those include files to compile.

I'm perfectly fine if it's in separate subpackage with string "unsupported" or
whatever in the name.  As long as I have freedom to take a risk and install it.