Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 8331

Summary: ls -l hangs on catalogs owned by removed users
Product: [Retired] Red Hat Linux Reporter: Xyvind Eide <oyvind.eide>
Component: fileutilsAssignee: Bernhard Rosenkraenzer <bero>
Status: CLOSED RAWHIDE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-01-11 15:07:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Xyvind Eide 2000-01-10 13:54:19 UTC
When ls -l is run on a catalog containing catalog(s) owned by users no
longer existing on the system, ls hangs and the memory usage of the job
grows until linux hangs because of high load.

Example:

The catalog /home contains the catalog mm owned by the user marius, who
were removed from the system earlier today.

... /home > ls -l

listes the catalogs before mm in the alphabet, then ls hangs.

The command

... /home > ls -l mm

works fine, it gives the number of the now removed owner as owner of the
catalog.

The problem also is created by ftp users doing a long ls.

Comment 1 Bernhard Rosenkraenzer 2000-01-11 15:07:59 UTC
Fixed in rawhide.