Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 83262

Summary: Patch for Serverworks CSB6 Chipset support
Product: [Retired] Red Hat Linux Reporter: ananth
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED WORKSFORME QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: high    
Version: 8.0CC: dale_kaisner, john_hull, matt_domsch, robert_hentosh, tao
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-06-05 14:36:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Source Patches
none
Source Patches none

Description ananth 2003-02-01 01:59:54 UTC
Description of problem:

This patch fixes the following issues in Redhat 8.0, IDE Driver with 
Serverworks CSB6 Chipset :

1. Device ordering issues between Tertiary & Primary channels. Disk on Tertiary 
channel shows up as hda instead of hde.

2. Newer revision of CSB6 (Device ID 0x217) is not recognized and shows up 
as 'Unknown PCI IDE Controller'.

3. System Freeze in event of an error if in UDMA transfer mode with CDROM.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
This patch can also be applied against Redhat errata kernel 2.4.18-23.

Comment 1 ananth 2003-02-01 02:06:17 UTC
Created attachment 89756 [details]
Source Patches

Comment 2 ananth 2003-02-01 02:08:34 UTC
Created attachment 89757 [details]
Source Patches

Comment 3 ananth 2003-02-01 02:15:51 UTC
This replaces bug 83239

Comment 4 Jeff Garzik 2003-02-13 19:49:04 UTC
*** Bug 83239 has been marked as a duplicate of this bug. ***

Comment 5 Larry Troan 2003-02-21 20:32:51 UTC
ISUE TRACKER 16297, opened by serverworks as sev 1.

Comment 6 Larry Troan 2003-03-11 19:59:33 UTC
FROM ISSUE TRACKER....
Event posted 02-21-2003 05:54pm by rhentosh with duration of 0.00        
GinGin is not the issue here. In fact most of what we want already works there.
Except for displaying the "primary | secondary | tertiary" channels as "primary
| secondary | primary | secondary disabled" in GinGin. I will have to verify if
adequate testing was done on DMA on the third channel IDE with the CDROM (I
belive that works).


The problem is the Milan errata. Currently the tertiary channel is not displayed
in the /proc filesystem and you can not enable DMA mode on the third channel. 
These are the two issues which need to be patched and a schedule for when the
errata will appear to fix the issue in Milan.


The device order problem is an issue in all OS's.  The third channel appears
first, if you stick a harddrive on the third channel it will show up as the C:
drive before harddrives on the primary and secondary. Dell will only ship the
machine with the CDROM cabled to the 3rd channel.  Hard drives will be cabled
only to the first two connectors. Please do not change the PCI ordering, it is
working as expected.    

---------------------------------
Event posted 02-23-2003 03:51pm by ltroan with duration of 0.00 
Robert,
Understand this is not gingin; however milan errata will be pushed thru QA after
gingin gold. Also, MKJ says the new kernel will be based off a derivative of the
gingin kernel.

Comment 7 Alan Cox 2003-06-05 14:36:42 UTC
Our current errata are built of the 7.0x IDE code so have CSB6IDE2 and know
about bios stuff.